Bug 167374 - xscreensaver-demo generates bad option for squiral
xscreensaver-demo generates bad option for squiral
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xscreensaver (Show other bugs)
4
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Ray Strode [halfline]
:
: 167373 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-01 18:53 EDT by Bob Schmertz
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-06 10:38:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to change -density option (705 bytes, patch)
2005-09-05 13:36 EDT, Mamoru TASAKA
no flags Details | Diff

  None (edit)
Description Bob Schmertz 2005-09-01 18:53:31 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050720 Fedora/1.0.6-1.1.fc4 Firefox/1.0.6

Description of problem:
The graphical config tool, when configuring the "squiral" screensaver, presents a slider widget for choosing "Density".  Moving this slider causes the tool to create a "-density" command-line option for squiral, but no such option is recognized by squiral.  Squiral won't run again until you remove that command-line option using the Advanced mode.

Version-Release number of selected component (if applicable):
xscreensaver-extras-4.21-4

How reproducible:
Always

Steps to Reproduce:
1. Start xscreensaver-demo (Desktop->Preferences->Screensaver)
2. Select Squiral from the list of screensavers
3. Click Settings under the preview window
4. Find the slider labeled "Density" (Sparse <--> Dense)
5. Move it one way or the other
6. Click OK.
  

Actual Results:  Naive version: Preview window showed "No preview available", and clicking Preview showed a black screen.

Enlightened version: a "-density" option was added to the command line by the GUI tool.

Expected Results:  Naive version: Preview should show squiral in operation, with the squiralies packed all dense and stuff.

Enlightened version: The GUI shouldn't generate a -density option, though I'm at a loss as to what "Density" is supposed to mean w.r.t. the actual available options.  It would also be nice if squiral would just ignore invalid options and drive on.

Additional info:

There is a general lack of correlation between the parameters on the GUI and the command-line params for squiral.  I can't tell which things map to which without futzing with the GUI and then checking the command-line to see what it generates.
Comment 1 Mamoru TASAKA 2005-09-05 13:36:20 EDT
Created attachment 118477 [details]
Patch to change -density option 

I can easily reproduce this.
From manual file and source file, squiral does not seem
to support -density option, which should be -fill option
( -fill option is supported but not appers on demo ).

I attached a patch against squiral.xml ( which is to be
installed in /usr/share/xscreensaver/config/ ) to fix 
 -density option.
Comment 2 Ray Strode [halfline] 2005-09-06 10:38:30 EDT
Thanks, applied.

Should be fixed in tomorrow's Rawhide.
Comment 3 Ray Strode [halfline] 2005-09-06 14:45:16 EDT
*** Bug 167373 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.