Bug 167400 - Installer hangs while playing test sound, and no sound at all.
Installer hangs while playing test sound, and no sound at all.
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-02 07:52 EDT by Stefan Geuns
Modified: 2015-01-04 17:21 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-04 21:30:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stefan Geuns 2005-09-02 07:52:36 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050720 Fedora/1.0.6-1.1.fc4 Firefox/1.0.6

Description of problem:
When I installed fedora core 4 I clicked the "play test sound" button at the first boot screen my laptop locked up. Everytime I boot into fc4 I have no sound. Laptop details are at additional information. 
I found a solution, and that is:

Close all sound programs, including kmix, xmms and artsd. Then run:
/sbin/rmmod snd-intel8x0
/sbin/insmod /lib/modules/2.6.12-1.1398_FC4/kernel/sound/pci/snd-intel8x0.ko

After these 2 commands my sound works (and after unmuting things in alsamixer or kmix).

However, I have to do this every reboot.


If I run the sound testing program before deleting and inserting the module, it locks up.

Version-Release number of selected component (if applicable):
kernel-2.6.12-1.1398_FC4

How reproducible:
Always

Steps to Reproduce:
1. reboot 
2.
3.
  

Actual Results:  no sound

Expected Results:  Play sounds

Additional info:

Laptop details:
NEC Versa P550
Pentium M 1.86 GHz, Centrino platform, 1 GB Ram

lspci output:
00:00.0 Host bridge: Intel Corporation Mobile 915GM/PM/GMS/910GML Express Processor to DRAM Controller (rev 03)
00:01.0 PCI bridge: Intel Corporation Mobile 915GM/PM Express PCI Express Root Port (rev 03)
00:1d.0 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #1 (rev 04)
00:1d.1 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #2 (rev 04)
00:1d.2 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #3 (rev 04)
00:1d.3 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #4 (rev 04)
00:1d.7 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB2 EHCI Controller (rev 04)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev d4)
00:1e.2 Multimedia audio controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) AC'97 Audio Controller (rev 04)
00:1e.3 Modem: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) AC'97 Modem Controller (rev 04)
00:1f.0 ISA bridge: Intel Corporation 82801FBM (ICH6M) LPC Interface Bridge (rev 04)
00:1f.1 IDE interface: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) IDE Controller (rev 04)
00:1f.3 SMBus: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) SMBus Controller (rev 04)
01:00.0 VGA compatible controller: ATI Technologies Inc M22 [Radeon Mobility M300]
06:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8169 Gigabit Ethernet (rev 10)
06:01.0 CardBus bridge: Texas Instruments PCI4510 PC card Cardbus Controller (rev 02)
06:01.1 FireWire (IEEE 1394): Texas Instruments PCI4510 IEEE-1394 Controller
06:03.0 Network controller: Intel Corporation PRO/Wireless 2915ABG MiniPCI Adapter (rev 05)

Maybe relevant dmesg output:
ACPI: PCI Interrupt Link [LNKF] (IRQs 9) *0, disabled.
ACPI: PCI Interrupt Link [LNKG] (IRQs 10) *0, disabled.

Alsa version:
alsa-utils-1.0.9rf-14.rhfc4.at
alsa-lib-devel-1.0.9rf-21.rhfc4.at
alsa-lib-1.0.9rf-21.rhfc4.at
Comment 1 Stefan Geuns 2005-09-10 14:50:35 EDT
A friend of mine found a way to get it to work, add the snd-intel8x0 to
/etc/hotplug/blacklist
I don't know if this is fixed in the 2.6.13 release of the kernel or if it is
fixed in newer versions of the kernel 2.6.12.
Comment 2 Stefan Geuns 2005-09-12 10:33:47 EDT
Sorry for replying again to my own post, in my last post I forgot the m, the
right module to add to the blacklist file is: snd-intel8x0m
Comment 3 Dave Jones 2005-09-23 21:38:29 EDT
can you remove the blacklisting, and retry with the test kernel from
updates-testing ?
Comment 4 Stefan Geuns 2005-10-01 03:42:53 EDT
Sorry for the late reply, was working on my ipw2200 problems at school. 
Couldn't find a kernel in updates-testing so I installed the 2.6.13 kernel (I
think you meant that one). I commented out the line in the blacklist and
rebooted into the new kernel, but unfortunatly the problem is still there, no
sound. Note that I don't get messages as sound card busy. xmms starts playing
but stops immediatly at 00:00. 
If I rmmod the snd-intel8x0 (without the m) and then modprobe it again, I have
sound. 
Comment 5 Dave Jones 2005-11-10 16:54:52 EST
Mass update to all FC4 bugs:

An update has been released (2.6.14-1.1637_FC4) which rebases to a new upstream
kernel (2.6.13.2). As there were ~3500 changes upstream between this and the
previous kernel, it's possible your bug has been fixed already.

Please retest with this update, and update this bug if necessary.

Thanks.

Comment 6 Dave Jones 2006-02-03 01:16:19 EST
This is a mass-update to all currently open kernel bugs.

A new kernel update has been released (Version: 2.6.15-1.1830_FC4)
based upon a new upstream kernel release.

Please retest against this new kernel, as a large number of patches
go into each upstream release, possibly including changes that
may address this problem.

This bug has been placed in NEEDINFO_REPORTER state.
Due to the large volume of inactive bugs in bugzilla, if this bug is
still in this state in two weeks time, it will be closed.

Should this bug still be relevant after this period, the reporter
can reopen the bug at any time. Any other users on the Cc: list
of this bug can request that the bug be reopened by adding a
comment to the bug.

If this bug is a problem preventing you from installing the
release this version is filed against, please see bug 169613.

Thank you.
Comment 7 John Thacker 2006-05-04 21:30:12 EDT
Closing per previous comment.
Comment 8 Stefan Geuns 2006-05-08 07:56:03 EDT
I installed core 5 yesterday and the problem is solved.

Note You need to log in before you can comment on or make changes to this bug.