Bug 1674000 - selinux role: Ansible linux system role for selinux should list all variables in defaults/main.yml
Summary: selinux role: Ansible linux system role for selinux should list all variables...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: rhel-system-roles
Version: 7.7
Hardware: Unspecified
OS: Unspecified
high
unspecified
Target Milestone: rc
: ---
Assignee: Pavel Cahyna
QA Contact: David Jež
URL:
Whiteboard:
Depends On:
Blocks: 1674004 1691973
TreeView+ depends on / blocked
 
Reported: 2019-02-08 17:00 UTC by Marek Hulan
Modified: 2019-10-17 09:15 UTC (History)
6 users (show)

Fixed In Version: rhel-system-roles-1.0-8.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1674004 (view as bug list)
Environment:
Last Closed: 2019-08-06 17:31:34 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github linux-system-roles selinux pull 33 0 'None' closed Move defaults to defaults/main.yml 2021-02-09 09:20:11 UTC
Github linux-system-roles selinux pull 43 0 'None' closed List all variables in defaults. 2021-02-09 09:20:11 UTC
Github linux-system-roles timesync pull 15 0 'None' closed Add empty timesync_ntp_provider to defaults 2021-02-09 09:20:11 UTC
Red Hat Product Errata RHBA-2019:2387 0 None None None 2019-08-06 17:31:41 UTC

Description Marek Hulan 2019-02-08 17:00:16 UTC
Description of problem:

Satellite 6 requires variables to be listed in defaults/main.yml in order to import/display them in UI. Some of variables such as the one for setting the policy is not listed there and default is hardcoded in tasks/main.yml. After a discussion with pcahyna, it should be posible to extract all of them.

Version-Release number of selected component (if applicable):

last released version, 1.0.0

How reproducible:

allways


Steps to Reproduce:
1. look at role directory
2.
3.

Actual results:

defaults directory is missing

Expected results:

all variables have entry in defaults/main.yml


Additional info:

in master branch, some of variables are already there

Comment 2 Pavel Cahyna 2019-02-08 17:05:45 UTC
The easy cases are there (in master), what is missing is selinux_state and selinux_policy, whose absence has a special meaning. It would be needed to let "null" have this special meaning instead and set the defaults to null.

Comment 6 Pavel Cahyna 2019-04-15 08:31:21 UTC
Do the values matter in any way, or is it enough for the variables to be listed? In some cases the values will be complex Jinja2 expressions, so trying to interpret them would be unlikely to be helpful.

Comment 7 Marek Hulan 2019-04-15 15:26:23 UTC
These values would be imported as default values. If users don't override them, they do not matter and defaults from ansible roles will be used. In other words, feel free to use whatever complicated expression you need, people may see "{{ whatever magic }}" as a default value in UI.

Comment 13 errata-xmlrpc 2019-08-06 17:31:34 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:2387


Note You need to log in before you can comment on or make changes to this bug.