Bug 1674004 - Ansible linux system role for selinux should list all variables in defaults/main.yml
Summary: Ansible linux system role for selinux should list all variables in defaults/m...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: rhel-system-roles
Version: 8.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: 8.0
Assignee: Pavel Cahyna
QA Contact: David Jež
URL:
Whiteboard:
Depends On: 1674000
Blocks: 1691973
TreeView+ depends on / blocked
 
Reported: 2019-02-08 17:07 UTC by Pavel Cahyna
Modified: 2019-07-30 19:32 UTC (History)
7 users (show)

Fixed In Version: rhel-system-roles-1.0-6.el8
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1674000
: 1691973 (view as bug list)
Environment:
Last Closed: 2019-07-30 19:32:33 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:1995 None None None 2019-07-30 19:32:41 UTC
Github linux-system-roles selinux pull 33 None None None 2019-02-08 17:08:17 UTC
Github linux-system-roles selinux pull 43 None None None 2019-05-29 16:23:06 UTC

Description Pavel Cahyna 2019-02-08 17:07:32 UTC
+++ This bug was initially created as a clone of Bug #1674000 +++

Description of problem:

Satellite 6 requires variables to be listed in defaults/main.yml in order to import/display them in UI. Some of variables such as the one for setting the policy is not listed there and default is hardcoded in tasks/main.yml. After a discussion with pcahyna, it should be posible to extract all of them.

Version-Release number of selected component (if applicable):

last released version, 1.0.0

How reproducible:

allways


Steps to Reproduce:
1. look at role directory
2.
3.

Actual results:

defaults directory is missing

Expected results:

all variables have entry in defaults/main.yml


Additional info:

in master branch, some of variables are already there

--- Additional comment from Red Hat Bugzilla Rules Engine on 2019-02-08 17:00:20 UTC ---

Since this bug report was entered in Red Hat Bugzilla, the release flag has been set to ? to ensure that it is properly evaluated for this release.

--- Additional comment from Pavel Cahyna on 2019-02-08 17:05:45 UTC ---

The easy cases are there (in master), what is missing is selinux_state and selinux_policy, whose absence has a special meaning. It would be needed to let "null" have this special meaning instead and set the defaults to null.

Comment 2 Pavel Cahyna 2019-05-31 07:44:00 UTC
test is available as tests/tests_default_vars.yml in the selinux role

Comment 3 Pavel Cahyna 2019-06-03 16:29:13 UTC
... and in the timesync role for the analogous problem in timesync

Comment 7 errata-xmlrpc 2019-07-30 19:32:33 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:1995


Note You need to log in before you can comment on or make changes to this bug.