Bug 1674826 - dpm-contrib-admintools: FTBFS: No CMAKE_C_COMPILER could be found. [NEEDINFO]
Summary: dpm-contrib-admintools: FTBFS: No CMAKE_C_COMPILER could be found.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: dpm-contrib-admintools
Version: 29
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Petr Pisar
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1603823 (view as bug list)
Depends On:
Blocks: F29FTBFS F30FTBFS 1585626
TreeView+ depends on / blocked
 
Reported: 2019-02-11 17:06 UTC by Fedora Release Engineering
Modified: 2019-07-03 02:01 UTC (History)
5 users (show)

Fixed In Version: dpm-contrib-admintools-0.2.4-4.fc31 dpm-contrib-admintools-0.2.4-4.fc30 dpm-contrib-admintools-0.2.4-3.fc29
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-07-03 01:15:46 UTC
releng: needinfo? (rocha.porto)


Attachments (Terms of Use)
build.log (1.00 KB, text/plain)
2019-02-11 17:06 UTC, Fedora Release Engineering
no flags Details
root.log (1.00 KB, text/plain)
2019-02-11 17:06 UTC, Fedora Release Engineering
no flags Details
state.log (681 bytes, text/plain)
2019-02-11 17:06 UTC, Fedora Release Engineering
no flags Details

Description Fedora Release Engineering 2019-02-11 17:06:02 UTC
dpm-contrib-admintools failed to build from source in Fedora rawhide/f30

https://koji.fedoraproject.org/koji/taskinfo?taskID=32377265


For details on the mass rebuild see:

https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
Please fix dpm-contrib-admintools at your earliest convenience and set the bug's status to
ASSIGNED when you start fixing it. If the bug remains in NEW state for 8 weeks,
dpm-contrib-admintools will be orphaned. Before branching of Fedora 31,
dpm-contrib-admintools will be retired, if it still fails to build.

For more details on the FTBFS policy, please visit:
https://fedoraproject.org/wiki/Fails_to_build_from_source

Comment 1 Fedora Release Engineering 2019-02-11 17:06:04 UTC
Created attachment 1529759 [details]
build.log

file build.log too big, will only attach last 1024 bytes

Comment 2 Fedora Release Engineering 2019-02-11 17:06:05 UTC
Created attachment 1529760 [details]
root.log

file root.log too big, will only attach last 1024 bytes

Comment 3 Fedora Release Engineering 2019-02-11 17:06:07 UTC
Created attachment 1529761 [details]
state.log

Comment 4 Fedora Release Engineering 2019-04-26 23:26:43 UTC
Dear Maintainer,

your package has not been built successfully in f30. Action is required from you.

If you can fix your package to build, perform a build in koji, and either create
an update in bodhi, or close this bug without creating an update, if updating is
not appropriate [1]. If you are working on a fix, set the status to ASSIGNED to
acknowledge this. Following the latest policy for such packages [2], your package
can be orphaned if this bug remains in NEW state more than 8 weeks.

[1] https://fedoraproject.org/wiki/Updates_Policy
[2] https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/

Comment 5 Petr Pisar 2019-06-20 14:00:52 UTC
*** Bug 1603823 has been marked as a duplicate of this bug. ***

Comment 6 Petr Pisar 2019-06-20 14:02:18 UTC
+ /usr/bin/cmake -DCMAKE_C_FLAGS_RELEASE:STRING=-DNDEBUG -DCMAKE_CXX_FLAGS_RELEASE:STRING=-DNDEBUG -DCMAKE_Fortran_FLAGS_RELEASE:STRING=-DNDEBUG -DCMAKE_VERBOSE_MAKEFILE:BOOL=ON -DCMAKE_INSTALL_PREFIX:PATH=/usr -DINCLUDE_INSTALL_DIR:PATH=/usr/include -DLIB_INSTALL_DIR:PATH=/usr/lib64 -DSYSCONF_INSTALL_DIR:PATH=/etc -DSHARE_INSTALL_PREFIX:PATH=/usr/share -DLIB_SUFFIX=64 -DBUILD_SHARED_LIBS:BOOL=ON . -DCMAKE_INSTALL_PREFIX=/ -DPYTHON_SITELIB=
-- The C compiler identification is unknown
-- The CXX compiler identification is unknown
BUILDSTDERR: CMake Error at CMakeLists.txt:3 (project):
BUILDSTDERR:   No CMAKE_C_COMPILER could be found.
BUILDSTDERR:   Tell CMake where to find the compiler by setting either the environment
BUILDSTDERR:   variable "CC" or the CMake cache entry CMAKE_C_COMPILER to the full path to
BUILDSTDERR:   the compiler, or to the compiler name if it is in the PATH.
BUILDSTDERR: CMake Error at CMakeLists.txt:3 (project):
BUILDSTDERR:   No CMAKE_CXX_COMPILER could be found.
BUILDSTDERR:   Tell CMake where to find the compiler by setting either the environment
BUILDSTDERR:   variable "CXX" or the CMake cache entry CMAKE_CXX_COMPILER to the full path
BUILDSTDERR:   to the compiler, or to the compiler name if it is in the PATH.
-- Configuring incomplete, errors occurred!

Comment 7 Petr Pisar 2019-06-20 14:17:51 UTC
Actually that had already been fixed by build-requires gcc and gcc-c++. The next issue was forbidden unversioned python interpreter.

Comment 8 Fedora Update System 2019-06-20 15:17:10 UTC
FEDORA-2019-a77e9c215e has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-a77e9c215e

Comment 9 Fedora Update System 2019-06-20 15:17:20 UTC
FEDORA-2019-5c1e900c63 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2019-5c1e900c63

Comment 10 Fedora Update System 2019-06-22 02:46:03 UTC
dpm-contrib-admintools-0.2.4-3.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-5c1e900c63

Comment 11 Fedora Update System 2019-06-22 06:04:08 UTC
dpm-contrib-admintools-0.2.4-4.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-a77e9c215e

Comment 12 Fedora Update System 2019-07-03 01:15:46 UTC
dpm-contrib-admintools-0.2.4-4.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.

Comment 13 Fedora Update System 2019-07-03 02:01:01 UTC
dpm-contrib-admintools-0.2.4-3.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.