Bug 1675256 - libAfterImage: FTBFS in Fedora rawhide/f30 [NEEDINFO]
Summary: libAfterImage: FTBFS in Fedora rawhide/f30
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: libAfterImage
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Andreas Bierfert
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F29FTBFS F30FTBFS 1708922
TreeView+ depends on / blocked
 
Reported: 2019-02-11 20:40 UTC by Fedora Release Engineering
Modified: 2019-05-30 13:19 UTC (History)
3 users (show)

Fixed In Version: libAfterImage-1.20-21.fc30 libAfterImage-1.20-21.fc28 libAfterImage-1.20-21.fc29 libAfterImage-1.20-21.el7 libAfterImage-1.20-21.el6
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-05-23 17:48:18 UTC
releng: needinfo? (andreas.bierfert)


Attachments (Terms of Use)
build.log (1.00 KB, text/plain)
2019-02-11 20:40 UTC, Fedora Release Engineering
no flags Details
root.log (1.00 KB, text/plain)
2019-02-11 20:40 UTC, Fedora Release Engineering
no flags Details
state.log (483 bytes, text/plain)
2019-02-11 20:40 UTC, Fedora Release Engineering
no flags Details

Description Fedora Release Engineering 2019-02-11 20:40:25 UTC
libAfterImage failed to build from source in Fedora rawhide/f30

https://koji.fedoraproject.org/koji/taskinfo?taskID=32406518


For details on the mass rebuild see:

https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
Please fix libAfterImage at your earliest convenience and set the bug's status to
ASSIGNED when you start fixing it. If the bug remains in NEW state for 8 weeks,
libAfterImage will be orphaned. Before branching of Fedora 31,
libAfterImage will be retired, if it still fails to build.

For more details on the FTBFS policy, please visit:
https://fedoraproject.org/wiki/Fails_to_build_from_source

Comment 1 Fedora Release Engineering 2019-02-11 20:40:27 UTC
Created attachment 1530876 [details]
build.log

file build.log too big, will only attach last 1024 bytes

Comment 2 Fedora Release Engineering 2019-02-11 20:40:29 UTC
Created attachment 1530877 [details]
root.log

file root.log too big, will only attach last 1024 bytes

Comment 3 Fedora Release Engineering 2019-02-11 20:40:30 UTC
Created attachment 1530878 [details]
state.log

Comment 4 Fedora Release Engineering 2019-04-26 23:28:50 UTC
Dear Maintainer,

your package has not been built successfully in f30. Action is required from you.

If you can fix your package to build, perform a build in koji, and either create
an update in bodhi, or close this bug without creating an update, if updating is
not appropriate [1]. If you are working on a fix, set the status to ASSIGNED to
acknowledge this. Following the latest policy for such packages [2], your package
can be orphaned if this bug remains in NEW state more than 8 weeks.

[1] https://fedoraproject.org/wiki/Updates_Policy
[2] https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/

Comment 5 Mattias Ellert 2019-05-10 11:25:47 UTC
*** Bug 1604550 has been marked as a duplicate of this bug. ***

Comment 6 Mattias Ellert 2019-05-10 11:33:52 UTC
This package is a dependency of one of the packages I maintain.

I the current maintainer does not react before it is orphaned by releng, I would like to maintain the package.

Comment 7 Mattias Ellert 2019-05-10 11:35:20 UTC
Sorry for the typo in the last comment... It should read: "If the current ..."

Comment 8 Fedora Update System 2019-05-14 11:17:01 UTC
libAfterImage-1.20-21.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2019-37ba387bca

Comment 9 Fedora Update System 2019-05-14 11:17:10 UTC
libAfterImage-1.20-21.fc30 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-bedeb1af38

Comment 10 Fedora Update System 2019-05-14 11:17:19 UTC
libAfterImage-1.20-21.el6 has been submitted as an update to Fedora EPEL 6. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-6389c91fe6

Comment 11 Fedora Update System 2019-05-14 11:17:27 UTC
libAfterImage-1.20-21.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-6a28a7fe8d

Comment 12 Fedora Update System 2019-05-14 11:17:37 UTC
libAfterImage-1.20-21.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2019-d4ddf39537

Comment 13 Fedora Update System 2019-05-15 00:44:27 UTC
libAfterImage-1.20-21.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-37ba387bca

Comment 14 Fedora Update System 2019-05-15 00:53:08 UTC
libAfterImage-1.20-21.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-bedeb1af38

Comment 15 Fedora Update System 2019-05-15 00:58:21 UTC
libAfterImage-1.20-21.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-6a28a7fe8d

Comment 16 Fedora Update System 2019-05-15 07:25:50 UTC
libAfterImage-1.20-21.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-d4ddf39537

Comment 17 Fedora Update System 2019-05-15 07:40:27 UTC
libAfterImage-1.20-21.el6 has been pushed to the Fedora EPEL 6 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-6389c91fe6

Comment 18 Fedora Update System 2019-05-23 17:48:18 UTC
libAfterImage-1.20-21.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.

Comment 19 Fedora Update System 2019-05-23 18:27:38 UTC
libAfterImage-1.20-21.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.

Comment 20 Fedora Update System 2019-05-24 21:49:19 UTC
libAfterImage-1.20-21.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.

Comment 21 Fedora Update System 2019-05-30 12:50:16 UTC
libAfterImage-1.20-21.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.

Comment 22 Fedora Update System 2019-05-30 13:19:04 UTC
libAfterImage-1.20-21.el6 has been pushed to the Fedora EPEL 6 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.