Bug 1676035 - sqlite2: FTBFS in Fedora rawhide/f30: ./lemon segmentation fault
Summary: sqlite2: FTBFS in Fedora rawhide/f30: ./lemon segmentation fault
Keywords:
Status: CLOSED DUPLICATE of bug 1556458
Alias: None
Product: Fedora
Classification: Fedora
Component: sqlite2
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Alex Lancaster
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F30FTBFS
TreeView+ depends on / blocked
 
Reported: 2019-02-11 22:03 UTC by Fedora Release Engineering
Modified: 2019-02-21 13:26 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-02-21 13:26:43 UTC


Attachments (Terms of Use)
build.log (1.00 KB, text/plain)
2019-02-11 22:03 UTC, Fedora Release Engineering
no flags Details
root.log (1.00 KB, text/plain)
2019-02-11 22:03 UTC, Fedora Release Engineering
no flags Details
state.log (629 bytes, text/plain)
2019-02-11 22:03 UTC, Fedora Release Engineering
no flags Details

Description Fedora Release Engineering 2019-02-11 22:03:26 UTC
sqlite2 failed to build from source in Fedora rawhide/f30

https://koji.fedoraproject.org/koji/taskinfo?taskID=32499916


For details on the mass rebuild see:

https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
Please fix sqlite2 at your earliest convenience and set the bug's status to
ASSIGNED when you start fixing it. If the bug remains in NEW state for 8 weeks,
sqlite2 will be orphaned. Before branching of Fedora 31,
sqlite2 will be retired, if it still fails to build.

For more details on the FTBFS policy, please visit:
https://fedoraproject.org/wiki/Fails_to_build_from_source

Comment 1 Fedora Release Engineering 2019-02-11 22:03:29 UTC
Created attachment 1533067 [details]
build.log

file build.log too big, will only attach last 1024 bytes

Comment 2 Fedora Release Engineering 2019-02-11 22:03:30 UTC
Created attachment 1533068 [details]
root.log

file root.log too big, will only attach last 1024 bytes

Comment 3 Fedora Release Engineering 2019-02-11 22:03:32 UTC
Created attachment 1533069 [details]
state.log

Comment 4 Petr Pisar 2019-02-21 13:16:31 UTC
A build log on ppc64le:

gcc -O2 -g -pipe -Wall -Werror=format-security -Wp,-D_FORTIFY_SOURCE=2 -Wp,-D_GLIBCXX_ASSERTIONS -fexceptions -fstack-protector-strong -grecord-gcc-switches -specs=/usr/lib/rpm/redhat/redhat-hardened-cc1 -specs=/usr/lib/rpm/redhat/redhat-annobin-cc1 -m64 -mcpu=power8 -mtune=power8 -fasynchronous-unwind-tables -fstack-clash-protection -DNDEBUG=1 -o lemon ./tool/lemon.c
[...]
cp ./tool/lempar.c .
cp ./src/parse.y .
./lemon parse.y
BUILDSTDERR: make: *** [Makefile:263: parse.c] Segmentation fault (core dumped)

It seems that it bundles a lemon version that crashes everywhere except x86_64 and i686.

Comment 5 Petr Pisar 2019-02-21 13:26:43 UTC

*** This bug has been marked as a duplicate of bug 1556458 ***


Note You need to log in before you can comment on or make changes to this bug.