Bug 1556458 - sqlite2: FTBFS in F28: ./lemon segmentation fault
Summary: sqlite2: FTBFS in F28: ./lemon segmentation fault
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: sqlite2
Version: 28
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Alex Lancaster
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1540885 1606408 1676035 (view as bug list)
Depends On:
Blocks: F29FTBFS F30FTBFS 1551327 F28FTBFS
TreeView+ depends on / blocked
 
Reported: 2018-03-14 23:55 UTC by Fedora Release Engineering
Modified: 2019-06-01 04:02 UTC (History)
3 users (show)

Fixed In Version: sqlite2-2.8.17-28.fc30 sqlite2-2.8.17-28.fc29
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-04-16 03:55:23 UTC


Attachments (Terms of Use)
build.log (21.97 KB, text/plain)
2018-05-28 08:13 UTC, Fedora Release Engineering
no flags Details
root.log (69.56 KB, text/plain)
2018-05-28 08:13 UTC, Fedora Release Engineering
no flags Details
state.log (627 bytes, text/plain)
2018-05-28 08:13 UTC, Fedora Release Engineering
no flags Details

Description Fedora Release Engineering 2018-03-14 23:55:28 UTC
Your package sqlite2 failed to build from source in current F28.

https://koji.fedoraproject.org/koji/taskinfo?taskID=24897856

For details on mass rebuild see https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild

Comment 1 Fedora Release Engineering 2018-05-28 08:13:46 UTC
Created attachment 1442866 [details]
build.log

Comment 2 Fedora Release Engineering 2018-05-28 08:13:54 UTC
Created attachment 1442867 [details]
root.log

Comment 3 Fedora Release Engineering 2018-05-28 08:13:59 UTC
Created attachment 1442868 [details]
state.log

Comment 4 Zbigniew Jędrzejewski-Szmek 2018-07-09 04:08:34 UTC
Dear Maintainer,

your package has not been built successfully in F28. Action is required from you.

If you can fix your package to build, perform a build in koji, and either create
an update in bodhi, or close this bug without creating an update, if updating is
not appropriate [1]. If you are working on a fix, set the status to ASSIGNED to acknowledge this. Following the latest policy for such packages [2], your package will be orphaned if this bug remains in NEW state more than 8 weeks.

[1] https://fedoraproject.org/wiki/Updates_Policy
[2] https://fedoraproject.org/wiki/Fails_to_build_from_source#Package_Removal_for_Long-standing_FTBFS_bugs

Comment 5 Petr Pisar 2019-02-21 13:26:01 UTC
A build log on ppc64le:

gcc -O2 -g -pipe -Wall -Werror=format-security -Wp,-D_FORTIFY_SOURCE=2 -Wp,-D_GLIBCXX_ASSERTIONS -fexceptions -fstack-protector-strong -grecord-gcc-switches -specs=/usr/lib/rpm/redhat/redhat-hardened-cc1 -specs=/usr/lib/rpm/redhat/redhat-annobin-cc1 -m64 -mcpu=power8 -mtune=power8 -fasynchronous-unwind-tables -fstack-clash-protection -DNDEBUG=1 -o lemon ./tool/lemon.c
[...]
cp ./tool/lempar.c .
cp ./src/parse.y .
./lemon parse.y
BUILDSTDERR: make: *** [Makefile:263: parse.c] Segmentation fault (core dumped)

It seems that it bundles a lemon version that crashes everywhere except x86_64 and i686.

Comment 6 Petr Pisar 2019-02-21 13:26:28 UTC
*** Bug 1606408 has been marked as a duplicate of this bug. ***

Comment 7 Petr Pisar 2019-02-21 13:26:43 UTC
*** Bug 1676035 has been marked as a duplicate of this bug. ***

Comment 8 Petr Pisar 2019-02-21 13:29:07 UTC
*** Bug 1540885 has been marked as a duplicate of this bug. ***

Comment 9 Fedora Update System 2019-04-10 20:56:55 UTC
sqlite2-2.8.17-28.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2019-52cc8671f5

Comment 10 Fedora Update System 2019-04-10 20:57:01 UTC
sqlite2-2.8.17-28.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2019-039fbdccd8

Comment 11 Fedora Update System 2019-04-10 20:57:06 UTC
sqlite2-2.8.17-28.fc30 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-73dc8a2f50

Comment 12 Fedora Update System 2019-04-12 02:37:39 UTC
sqlite2-2.8.17-28.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-52cc8671f5

Comment 13 Fedora Update System 2019-04-12 02:47:29 UTC
sqlite2-2.8.17-28.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-73dc8a2f50

Comment 14 Fedora Update System 2019-04-12 03:56:12 UTC
sqlite2-2.8.17-28.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-039fbdccd8

Comment 15 Fedora Update System 2019-04-16 03:55:23 UTC
sqlite2-2.8.17-28.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.

Comment 16 Fedora Update System 2019-06-01 04:02:21 UTC
sqlite2-2.8.17-28.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.