Bug 1676230 - xfce-theme-manager: FTBFS in Fedora rawhide/f30
Summary: xfce-theme-manager: FTBFS in Fedora rawhide/f30
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: xfce-theme-manager
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Eduardo Echeverria
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1640781 (view as bug list)
Depends On:
Blocks: F30FTBFS
TreeView+ depends on / blocked
 
Reported: 2019-02-11 22:23 UTC by Fedora Release Engineering
Modified: 2019-07-29 01:44 UTC (History)
3 users (show)

Fixed In Version: xfce-theme-manager-0.3.8-1.fc30 xfce-theme-manager-0.3.8-1.fc29
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-07-29 01:08:18 UTC


Attachments (Terms of Use)
build.log (1.00 KB, text/plain)
2019-02-11 22:23 UTC, Fedora Release Engineering
no flags Details
root.log (1.00 KB, text/plain)
2019-02-11 22:23 UTC, Fedora Release Engineering
no flags Details
state.log (665 bytes, text/plain)
2019-02-11 22:23 UTC, Fedora Release Engineering
no flags Details

Description Fedora Release Engineering 2019-02-11 22:23:26 UTC
xfce-theme-manager failed to build from source in Fedora rawhide/f30

https://koji.fedoraproject.org/koji/taskinfo?taskID=32510343


For details on the mass rebuild see:

https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
Please fix xfce-theme-manager at your earliest convenience and set the bug's status to
ASSIGNED when you start fixing it. If the bug remains in NEW state for 8 weeks,
xfce-theme-manager will be orphaned. Before branching of Fedora 31,
xfce-theme-manager will be retired, if it still fails to build.

For more details on the FTBFS policy, please visit:
https://fedoraproject.org/wiki/Fails_to_build_from_source

Comment 1 Fedora Release Engineering 2019-02-11 22:23:28 UTC
Created attachment 1533643 [details]
build.log

file build.log too big, will only attach last 1024 bytes

Comment 2 Fedora Release Engineering 2019-02-11 22:23:29 UTC
Created attachment 1533644 [details]
root.log

file root.log too big, will only attach last 1024 bytes

Comment 3 Fedora Release Engineering 2019-02-11 22:23:31 UTC
Created attachment 1533645 [details]
state.log

Comment 4 Fedora Release Engineering 2019-04-26 23:34:15 UTC
Dear Maintainer,

your package has not been built successfully in f30. Action is required from you.

If you can fix your package to build, perform a build in koji, and either create
an update in bodhi, or close this bug without creating an update, if updating is
not appropriate [1]. If you are working on a fix, set the status to ASSIGNED to
acknowledge this. Following the latest policy for such packages [2], your package
can be orphaned if this bug remains in NEW state more than 8 weeks.

[1] https://fedoraproject.org/wiki/Updates_Policy
[2] https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/

Comment 5 Fedora Release Engineering 2019-06-03 21:48:31 UTC
Dear Maintainer,

your package has not been built successfully in f30. Action is required from you.

If you can fix your package to build, perform a build in koji, and either create
an update in bodhi, or close this bug without creating an update, if updating is
not appropriate [1]. If you are working on a fix, set the status to ASSIGNED to
acknowledge this. Following the latest policy for such packages [2], your package
can be orphaned if this bug remains in NEW state more than 8 weeks.

[1] https://fedoraproject.org/wiki/Updates_Policy
[2] https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/

Comment 6 Fedora Release Engineering 2019-06-17 20:48:14 UTC
Dear Maintainer,

your package has not been built successfully in f30. Action is required from you.

If you can fix your package to build, perform a build in koji, and either create
an update in bodhi, or close this bug without creating an update, if updating is
not appropriate [1]. If you are working on a fix, set the status to ASSIGNED to
acknowledge this. Following the latest policy for such packages [2], your package
can be orphaned if this bug remains in NEW state more than 8 weeks.

[1] https://fedoraproject.org/wiki/Updates_Policy
[2] https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/

Comment 7 Fedora Release Engineering 2019-07-02 11:19:52 UTC
Dear Maintainer,

your package has not been built successfully in 30. Action is required from you.

If you can fix your package to build, perform a build in koji, and either create
an update in bodhi, or close this bug without creating an update, if updating is
not appropriate [1]. If you are working on a fix, set the status to ASSIGNED to
acknowledge this. Following the latest policy for such packages [2], your package
can be orphaned if this bug remains in NEW state more than 8 weeks.

A week before the mass branching of Fedora 31 according to the schedule [3],
any packages which still have open FTBFS bugs from Fedora 30 will be retired.

[1] https://fedoraproject.org/wiki/Updates_Policy
[2] https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/
[3] https://fedoraproject.org/wiki/Releases/31/Schedule

Comment 8 Fedora Release Engineering 2019-07-02 13:37:02 UTC
Dear Maintainer,

your package has not been built successfully in 30. Action is required from you.

If you can fix your package to build, perform a build in koji, and either create
an update in bodhi, or close this bug without creating an update, if updating is
not appropriate [1]. If you are working on a fix, set the status to ASSIGNED to
acknowledge this. Following the latest policy for such packages [2], your package
can be orphaned if this bug remains in NEW state more than 8 weeks.

A week before the mass branching of Fedora 31 according to the schedule [3],
any packages which still have open FTBFS bugs from Fedora 30 will be retired.

[1] https://fedoraproject.org/wiki/Updates_Policy
[2] https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/
[3] https://fedoraproject.org/wiki/Releases/31/Schedule

Comment 10 Filipe Rosset 2019-07-16 19:40:22 UTC
*** Bug 1640781 has been marked as a duplicate of this bug. ***

Comment 11 Filipe Rosset 2019-07-16 22:20:18 UTC
Fixed, can you please test the builds from your side? Thanks.

rawhide -> https://koji.fedoraproject.org/koji/taskinfo?taskID=36289463
f30		-> https://koji.fedoraproject.org/koji/taskinfo?taskID=36289517
f29		-> https://koji.fedoraproject.org/koji/taskinfo?taskID=36289525

Comment 12 Fedora Update System 2019-07-16 22:24:10 UTC
FEDORA-2019-fb84d34fe4 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2019-fb84d34fe4

Comment 13 Fedora Update System 2019-07-17 02:06:27 UTC
xfce-theme-manager-0.3.8-1.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-fb84d34fe4

Comment 14 Fedora Update System 2019-07-17 02:15:09 UTC
xfce-theme-manager-0.3.8-1.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-834bb8a3d9

Comment 15 Villy Kruse 2019-07-17 06:17:30 UTC
(In reply to Filipe Rosset from comment #11)
> Fixed, can you please test the builds from your side? Thanks.
> 
> rawhide -> https://koji.fedoraproject.org/koji/taskinfo?taskID=36289463
> f30		-> https://koji.fedoraproject.org/koji/taskinfo?taskID=36289517
> f29		-> https://koji.fedoraproject.org/koji/taskinfo?taskID=36289525

Installs find of f30.  That is the only system I have.

Comment 16 Fedora Update System 2019-07-29 01:08:18 UTC
xfce-theme-manager-0.3.8-1.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.

Comment 17 Fedora Update System 2019-07-29 01:44:49 UTC
xfce-theme-manager-0.3.8-1.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.