Bug 167662 - system-config-lvm hangs when making a LV with ext2 or ext3
system-config-lvm hangs when making a LV with ext2 or ext3
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: system-config-lvm (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jim Parsons
:
: 167847 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-06 14:59 EDT by Nate Straz
Modified: 2009-04-16 19:11 EDT (History)
2 users (show)

See Also:
Fixed In Version: rhel-4.2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-18 21:02:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nate Straz 2005-09-06 14:59:19 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.7.10) Gecko/20050720 Fedora/1.0.6-1.1.fc4 Firefox/1.0.6

Description of problem:
When I create a logical volume and select ext2 or ext3 as the file system on it,
the progress bar does not disappear after mkfs finished.  Once I strace the system-config-lvm subprocess the gui continues.  When I select "gfs (local)" the
GUI doesn't hang.

Version-Release number of selected component (if applicable):
system-config-lvm-1.0.3-1.0

How reproducible:
Always

Steps to Reproduce:
1. Make a LV with system-config-lvm and select ext2 or ext3 as the file system type.  

Actual Results:  The progress dialog stays up.

Expected Results:  The progress dialog should disappear and the system-config-lvm display refreshed.

Additional info:

The GUI probably should be using the -q flag to mkfs.

--- Filesystem.py.orig  2005-09-06 13:59:34.000000000 -0500
+++ Filesystem.py       2005-09-06 14:00:01.000000000 -0500
@@ -148,6 +148,7 @@
         args.append("/sbin/mkfs")
         args.append("-t")
         args.append('ext3')
+        args.append("-q")
         args.append(path)
         cmdstr = ' '.join(args)
         msg = CREATING_FS % (self.name)
@@ -254,6 +255,7 @@
         args.append("/sbin/mkfs")
         args.append("-t")
         args.append('ext2')
+        args.append("-q")
         args.append(path)
         cmdstr = ' '.join(args)
         msg = CREATING_FS % (self.name)
Comment 1 Stanko Kupcevic 2005-09-07 10:58:58 EDT
This is a more general bug that applies to progress bar (bz159482). 
Comment 4 Stanko Kupcevic 2005-09-08 18:38:00 EDT
Fixed in 1.0.4
Comment 5 Stanko Kupcevic 2005-09-08 18:43:07 EDT
*** Bug 167847 has been marked as a duplicate of this bug. ***
Comment 8 Nate Straz 2005-09-15 16:59:31 EDT
Verified in 1.0.5-1.0.
Comment 9 David Lawrence 2006-07-17 23:24:22 EDT
QA_READY has been deprecated in favor of ON_QA. Please use ON_QA in the future.
Moving to ON_QA.
Comment 10 Ben Levenson 2008-02-18 21:02:45 EST
this was released in rhel-4.2

Note You need to log in before you can comment on or make changes to this bug.