Bug 167847 - system-config-lvm: lvcreate hangs
system-config-lvm: lvcreate hangs
Status: CLOSED DUPLICATE of bug 167662
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: system-config-lvm (Show other bugs)
4.0
All Linux
medium Severity high
: ---
: ---
Assigned To: Jim Parsons
:
: 175175 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-08 16:36 EDT by Wendy Cheng
Modified: 2009-04-16 19:12 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-08 18:42:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Wendy Cheng 2005-09-08 16:36:02 EDT
Description of problem:

Using system-config-lvm to create new logical volume, the GUI would hang if:

* the lv size is above 30GB; and 
* filesystem (say ext3) is selected. 

If the filesystem is specified as "none", it works without troubles. 

Version-Release number of selected component (if applicable):
system-config-lvm-1.0.3-1.0

How reproducible:
each time and every time

Additional info:
1) customer used strace and found it hung at mkfs.
2) I did gdb attach, it hung at pthread's __write_nocancel():

#0  0x000000383cc0af22 in __write_nocancel () from /lib64/tls/libpthread.so.0
#1  0x000000383c6afd36 in PyOS_AfterFork () from /usr/lib64/libpython2.3.so.1.0
#2  0x000000383c6896df in _PyEval_SliceIndex () from /usr/lib64/libpython2.3.so.1.0
#3  0x000000383c689ba1 in _PyEval_SliceIndex () from /usr/lib64/libpython2.3.so.1.0

.. (other deleted).
Comment 1 Wendy Cheng 2005-09-08 16:49:01 EDT
Forgot to say,

I ran this on x86_64 machine and cww (our TAM) also recreated this issue on
i686. So it is not platform dependent. 
Comment 2 Stanko Kupcevic 2005-09-08 18:42:48 EDT
Duplicate of 167662. 
167662 will be in RHEL4U2, so removing from RHEL4U3Proposed.

*** This bug has been marked as a duplicate of 167662 ***
Comment 3 Stanko Kupcevic 2005-12-19 13:52:05 EST
*** Bug 175175 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.