Bug 167708 - Seeing manual pages by man or xscreensaver-demo fails
Seeing manual pages by man or xscreensaver-demo fails
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xscreensaver (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
:
: 161451 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-07 10:21 EDT by Mamoru TASAKA
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version: 4.24-3.fc5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-25 06:43:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
JPEG file which captured the window. (165.01 KB, image/jpeg)
2005-09-07 10:30 EDT, Mamoru TASAKA
no flags Details
Patch A: patch to direct correct manual page on demo (1.16 KB, patch)
2005-09-07 10:43 EDT, Mamoru TASAKA
no flags Details | Diff
Patch B: move man dir and also change man suffix (3.08 KB, patch)
2005-09-07 10:54 EDT, Mamoru TASAKA
no flags Details | Diff
More proper patch, for demo-Gtk.c (399 bytes, patch)
2006-02-12 14:36 EST, Mamoru TASAKA
no flags Details | Diff

  None (edit)
Description Mamoru TASAKA 2005-09-07 10:21:01 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.11) Gecko/20050901 Fedora/1.7.11-4

Description of problem:
A. Trying to see a xscreensaver manual page ( for example, xscreensaver-demo ) by
   /usr/bin/man command fail with a message "No manual entry for YYY".
B. Trying to see a xscreensaver hack manual page ( for example, penetrate ) by
   xscreensaver-demo tries to see the binary file of the hack itself.

Version-Release number of selected component (if applicable):
xscreensaver-4.21-11

How reproducible:
Always

Steps to Reproduce:
1. Save ~/.xscreensaver and make sure three xscreensaver-related rpms are installed.
2. Try "man xscreensaver-demo"
3. Run xscreensaver-demo, choose one hack, push "Settings" button and then push "Documentation" button.
  

Actual Results:  For step 2, seeing the manual page fails with a message "No manual entry for YYY"
For step 3, pushing "Documentation" button invokes man command, but man command tries to see the binary file of the hack itself, not the manual page of the hack.

Expected Results:  For step 2, seeing the manual page should success.
For step 3, man command should see the manual page of the hack correctly.

Additional info:
Comment 1 Mamoru TASAKA 2005-09-07 10:30:26 EDT
Created attachment 118562 [details]
JPEG file which captured the window.

JPEG file of the captured window when I tried the step 2 and step 3.
In this JPEG figure,

A. trying "man xscreensaver" fails with a message "No manual entry".
B. In xscreensaver-demo -> choose bouncingcow -> push Setting -> push
Documentation, gnome-terminal is invoked with displaying garbage messages. Its
title is "/usr/libexec/xscreensaver/bouncingcow manual" and man command sees
the binary file of bouncingcow itself.
Comment 2 Mamoru TASAKA 2005-09-07 10:43:51 EDT
Created attachment 118563 [details]
Patch A: patch to direct correct manual page on demo

Proposed patch A: patch for man command invoked by xscreensaver-demo to direct
the correct manual page of the hack.

This patch is related to the fix for bug 151677 or bug 156906. After this fix,
xscreensaver-demo command came to use the absolute path of the hack binary, but
man command invoked by Setting -> Documentation uses this absolute path, too (
at the line of *manualCommand in /usr/X11R6/lib/X11/app-defaults/XScreenSaver
).

This patch is intended that for man command, its argument should use only the
basename of the hack name with a absolute path.
Comment 3 Mamoru TASAKA 2005-09-07 10:54:47 EDT
Created attachment 118564 [details]
Patch B: move man dir and also change man suffix

Patch B: perhaps better fix for bug 166441.

When manual pages are moved to section 6, the suffix of manual pages should
coincide with the section number.

This patch is intended for:
1. Also change man page suffix, too.
2. Restrict man command invoked by xscreensaver-demo to see only in section 6
to avoid seeing the other manual page of the same name in another section.
3. Change the content of the manual page to coincide with section number. For
example, ant manual ( in xscreensaver-extras ) includes the description "SEE
ALSO  xscreensaver(1)".
Comment 4 Mamoru TASAKA 2005-09-07 11:00:05 EDT
Sorry, rpm version-relase is xscreensaver-4.22-11, not xscreensaver-4.21-11.
Comment 5 Ray Strode [halfline] 2005-09-07 11:48:03 EDT
Hi,
Patch B looks reasonable to me.  I'll commit it.

Thanks.
Comment 6 Mamoru TASAKA 2005-09-09 03:07:59 EDT
I verified that this bug is fixed in xscreensaver-4.22-13.
Thanks !!
Comment 7 Mamoru TASAKA 2006-02-12 14:23:50 EST
This bug revived in current rpm xscreensaver-4.24-1 again!
Comment 8 Mamoru TASAKA 2006-02-12 14:36:34 EST
Created attachment 124560 [details]
More proper patch, for demo-Gtk.c

More proper approach to fix broken manual pages, for demo-Gtk.c

In fedora rpm version 4.22-4.23, this problem used to be fixed by patching
against XScreensaver.ad. 
But after a closer check, it turned to be that this is the bug of the treatment
of a pointer in the function manual_cb() in demo-Gtk.c.
In manual_cb, some pointer movement is executed to find out the basename of a
hack, which proved to be wrong at one point.

This patch is for manual_cb() to find out the basename of a hack correctly;
this patch makes 2 patches above obsolete.
Comment 9 Mamoru TASAKA 2006-09-25 06:43:42 EDT
Seemingly fixed in 4.24-3.fc5.
Comment 10 Mamoru TASAKA 2007-01-22 11:01:11 EST
*** Bug 161451 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.