Bug 1677425 - RFE: add support for one time kernel/initrd specification for installs
Summary: RFE: add support for one time kernel/initrd specification for installs
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Virtualization Tools
Classification: Community
Component: virt-manager
Version: unspecified
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Cole Robinson
QA Contact:
URL:
Whiteboard:
: 1713356 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-02-14 21:11 UTC by Dusty Mabe
Modified: 2020-01-26 18:56 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-01-26 18:56:48 UTC


Attachments (Terms of Use)

Description Dusty Mabe 2019-02-14 21:11:41 UTC
Description of problem:

The `virt-install --boot` options allows you to specify a kernel and initrd for boot but it is a persistent setting and the machine will always boot with that kernel and initrd. I'd like to be able to specify exactly a kernel and initrd to boot but have that only be effective druing install.

So basically the equivalent of this:

```
virt-install --boot kernel=vmlinuz,initrd=initramfs.img,kernel_args="${args}"
```

for --location:

 virt-install --location $(pwd),kernel=vmlinuz,initrd=initramfs.img,kernel_args="${args}"

To be able to be done.

Comment 1 Cole Robinson 2019-06-16 15:51:13 UTC
*** Bug 1713356 has been marked as a duplicate of this bug. ***

Comment 2 Cole Robinson 2020-01-26 18:56:48 UTC
Thanks for the suggestion, this was implemented in virt-manager 2.2.0 with a --install option:

./virt-install --install help
  bootdev
  initrd
  kernel
  kernel_args
  kernel_args_overwrite
  no_install
  os

So, --install kernel=X,initrd=Y
--location has kernel= and initrd= options as well, but those are only for pointing to a path relative to
the --location $URL that is passed, incase virt-install can't find the media at that location.
So for the one time boot behavior, use --install


Note You need to log in before you can comment on or make changes to this bug.