Bug 1713356 - [RFE] Support local or remote direct kernel boot based install
Summary: [RFE] Support local or remote direct kernel boot based install
Keywords:
Status: CLOSED DUPLICATE of bug 1677425
Alias: None
Product: Virtualization Tools
Classification: Community
Component: virt-manager
Version: unspecified
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Cole Robinson
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-05-23 13:12 UTC by Yanko Kaneti
Modified: 2019-06-16 15:51 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-16 15:51:13 UTC


Attachments (Terms of Use)

Description Yanko Kaneti 2019-05-23 13:12:29 UTC
While one can post-creation configure a vm to directly boot a local kernel file, its supported by virt-install and the install wizard only indirectly (through autodetected media or tree links).

Seems to me using directly local or remote kernel+initrd combo file would be quite the straightforward way to boot installers or any kind or any other payload.

Best illustrated I think by https://netboot.xyz

i.e It would be nice to be able to give virt-manager/virt-install just 
https://boot.netboot.xyz/ipxe/netboot.xyz.lkrn  as location and for it to figure out the rest.

Comment 1 Cole Robinson 2019-05-23 14:08:37 UTC
Thanks for the suggestion. I've thought about adding this to virt-install, for a one time boot option.

The main problem with doing this for permanent config is that qemu can only boot off a local kernel/initrd, so we would need to either download it every boot or download it once and save it somewhere which the user can do anyways.

For the netboot case you _can_ point a VM at an HTTP hosted iso like https://boot.netboot.xyz/ipxe/netboot.xyz.iso and boot from that, although it'll consume their bandwidth for every boot so if it was a permanent set up it would still be nicer to download it locally and boot from that

Comment 2 Cole Robinson 2019-06-16 15:51:13 UTC
There's support for 'install from kernel path or URL' in virt-install now. I don't think we will be adding it to virt-manager because it's a pretty advanced case. Duping this to another similar bug where I will update with details when the new virt-manager release is out

*** This bug has been marked as a duplicate of bug 1677425 ***


Note You need to log in before you can comment on or make changes to this bug.