Bug 1678129 - Typo in root-config
Summary: Typo in root-config
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: root
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Mattias Ellert
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-02-18 07:52 UTC by nvwarr
Modified: 2019-03-07 21:15 UTC (History)
2 users (show)

Fixed In Version: root-6.16.00-3.fc29 root-6.16.00-3.fc30 root-6.16.00-3.fc31 root-6.16.00-3.fc28 root-6.16.00-3.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-03-01 02:38:10 UTC
Type: Bug


Attachments (Terms of Use)

Description nvwarr 2019-02-18 07:52:49 UTC
Description of problem:

root-config --libs gives an incorrect result

Version-Release number of selected component (if applicable):

root-core-6.16.00-1.fc30.x86_64

How reproducible:

Always

Steps to Reproduce:
1. root-config --libs

Actual results:

Should give the libraries needed to build root applications

Expected results:

There's a typo "-lROOTVecOps-lTree" (note there's no space between the two libraries) so builds fail with:

/usr/bin/ld: cannot find -lROOTVecOps-lTree
collect2: error: ld returned 1 exit status

Additional info:

Adding an extra space on line 75 of root-config fixes the problem.

Comment 1 nvwarr 2019-02-18 07:58:58 UTC
Hmm, this is showing up as a problem with Fedora 28. I'm sure I selected rawhide from the pull-down menu!

Comment 2 Fedora Update System 2019-02-20 08:29:50 UTC
js-jsroot-5.6.3-1.fc29 root-6.16.00-3.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2019-23ed568d47

Comment 3 Fedora Update System 2019-02-20 08:30:40 UTC
gsoap-2.8.60-6.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2019-aa62ca3119

Comment 4 Fedora Update System 2019-02-20 08:31:52 UTC
js-jsroot-5.6.3-1.el7 root-6.16.00-3.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-a1dfc40144

Comment 5 Fedora Update System 2019-02-21 12:28:33 UTC
js-jsroot-5.6.3-1.fc28 root-6.16.00-3.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2019-28fe03887c

Comment 6 Mattias Ellert 2019-02-21 12:31:24 UTC
(In reply to Fedora Update System from comment #3)
> gsoap-2.8.60-6.fc28 has been submitted as an update to Fedora 28.
> https://bodhi.fedoraproject.org/updates/FEDORA-2019-aa62ca3119

This was obviously a mistake. I have now tagged the correct update instead...

Comment 7 Mattias Ellert 2019-02-21 12:33:50 UTC
I should rebuild F30 and F31 too, but builds currently fail due to the unrelated bug #1678569. :-(

Comment 8 Fedora Update System 2019-03-01 02:38:10 UTC
js-jsroot-5.6.3-1.fc29, root-6.16.00-3.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.

Comment 9 Mattias Ellert 2019-03-01 06:45:04 UTC
Now also fixed in F30 and F31. Unrelated issues in openblas (bug #1678569) and libstdc++ (bug #1683339) blocking the builds were fixed.

Comment 10 Fedora Update System 2019-03-01 23:10:05 UTC
js-jsroot-5.6.3-1.fc28, root-6.16.00-3.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2019-03-07 21:15:44 UTC
js-jsroot-5.6.3-1.el7, root-6.16.00-3.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.