Bug 167817 - Requests for API enhancements to make organizations more controlable through the RHN API
Requests for API enhancements to make organizations more controlable through ...
Status: CLOSED DUPLICATE of bug 244725
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Other (Show other bugs)
unspecified
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Justin Sherrill
Red Hat Satellite QA List
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-08 10:49 EDT by Scott McBrien
Modified: 2008-03-10 16:55 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-10 16:55:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Scott McBrien 2005-09-08 10:49:44 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050719 Red Hat/1.0.6-1.4.1 Firefox/1.0.6

Description of problem:
Red Hat Global Learning Services uses hosted RHN to manage our organizational structure.  A little background info:
Every instructor, world-wide, is given an RHN account on our organization.  To ensure that one instructor does not run amuk, we generate activation keys, limited to 3 active systems, for them to register their systems to our organization.  This activation key also assigns their system to a system group.  This system group is created by an organizational admin, and the individual instructor's account is set as the administrator of that group.

I would like to use the API to automatedly create accounts for new users, and delete accounts for instructors who have left.  

To create an account I do the following:
Create their user account (currently in the API)
Create their system group (requested feature)
Assign the new user account to be the admin of the group (requested feature)
Create an activation key (requested feature)
Associate the activation key with the created system group (requested feature)

To disable the account:
Remove systems registered by this user (currently able to do using the API)
Delete the system group (requested feature)
Delete the activiation key (requested feature)
Delete the user account (currently in the API)

Having the above features would save me personally tons of time, but are all useful features for managing a diverse organization through RHN!

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.see above
2.
3.
  

Additional info:
Comment 1 Bret McMillan 2007-04-12 11:16:43 EDT
Removing from rhn501; Scott, I'd encourage you to open up a dialog w/ Rich
Friedman, RHN's head of product management; the RHN/Features bugzilla bucket
will probably get reconfigured in a few weeks, and Rich can help point you down
the best avenues to get your request prioritized.
Comment 3 Justin Sherrill 2008-03-10 16:55:10 EDT
All of these features will be available in sat 5.1 when it is released.  I'm
going to go ahead and close this bug as a duplicate.

*** This bug has been marked as a duplicate of 244725 ***

Note You need to log in before you can comment on or make changes to this bug.