Bug 167825 - Good: Kmail icon in notification area creates unremovable blank spaces
Good: Kmail icon in notification area creates unremovable blank spaces
Status: CLOSED DUPLICATE of bug 166160
Product: Fedora
Classification: Fedora
Component: gnome-applets (Show other bugs)
4
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-08 12:31 EDT by Hugh Redmon
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-08 12:49:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Hugh Redmon 2005-09-08 12:31:53 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050720 Fedora/1.0.6-1.1.fc4 Firefox/1.0.6

Description of problem:
I use Kmail on FC4 and when the mail icon docks into the notification area it 
has a problem.  I can click the icon in the notification area to open Kmail, 
but when I close it, the icon moves 1 space to left in the notification area.  
Everytime I open and close it, it moves 1 space to the left.  I cannot resize 
the notification area to get rid of the empty space it creates.  The spaces 
are there and nothing eliminates them but deleting the panel and adding it 
again.  Logging off my destop and restarting it fixes it, too.  Eventually, 
so many empty spaces forcing my mail icon to the left leaves me no space for 
open windows on my panel and I have to restart the notification area.  This 
also occured with FC3 and has been a problem ever since.  Is this a known bug 
and is there a fix for this?

Version-Release number of selected component (if applicable):
notification 2.10.1

How reproducible:
Always

Steps to Reproduce:
1. Add notification area to panel.
2. Start Kmail and mail sure icon appears in notification area.
3. Close Kmail and then click on the mail icon in notification area to open it again.
4. Close Kmail and observe mail icon moving to the left 1 space in the notification area.
  

Actual Results:  The mail icon moved 1 space to the left and you cannot delete the space it creates without deleting the nottification area nad then re-adding to the panel.

Expected Results:  The mail icon should go back to the same position inthe notification area and not create an unremovable blank space.

Additional info:
Comment 1 Hugh Redmon 2005-09-08 12:42:06 EDT
I just discovered that if you change the SysTray setting in Kmail to always show
the Kmail icon whether there is mail or not, the problem does not occur.  It
only occurs when you select "Only show kmail in the system tray if there are
unread messages" when configuring Kmail.  Selecting "Always show Kmail in the
system tray" causes it to create a blank space because the icon in the system
try disappears when you click on it and re-appears 1 space to the left when you
close Kmail.
Comment 2 Rahul Sundaram 2005-09-08 12:49:55 EDT
Thanks for the bug report. This particular bug has already been reported
into our bug tracking system, but please feel free to report any further
bugs you find.

*** This bug has been marked as a duplicate of 166160 ***

Note You need to log in before you can comment on or make changes to this bug.