Bug 167870 - maxima (and maxima-gui?) missing from Fedora Extras in Bugzilla
maxima (and maxima-gui?) missing from Fedora Extras in Bugzilla
Status: CLOSED DUPLICATE of bug 167786
Product: Bugzilla
Classification: Community
Component: Bugzilla General (Show other bugs)
2.8
All Linux
medium Severity medium (vote)
: ---
: ---
Assigned To: David Lawrence
David Lawrence
:
: 168071 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-08 23:12 EDT by Andre Robatino
Modified: 2007-04-18 13:31 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-09 21:39:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andre Robatino 2005-09-08 23:12:30 EDT
Description of problem:
  The packages maxima and maxima-gui, currently in Fedora Extras, are not in
Bugzilla.  There is a serious bug in maxima-gui I need to report (namely that
exiting xmaxima in the usual way causes a logout of the entire X session).

Version-Release number of selected component (if applicable):
current
Comment 1 Walter Neumann 2005-09-09 01:16:11 EDT
I confirm the same problem with xmaxima: logging out (or even just killing the
xmaxima window) logs out of the entire X session. Messages shows:

Sep  9 01:04:06 neumann gconfd (neumann-3902): Received signal 15, shutting down
cleanly
Sep  9 01:04:07 neumann gconfd (neumann-3902): Exiting

Version: maxima-gui-5.9.1-4.fc4
Comment 2 Andre Robatino 2005-09-09 02:00:05 EDT
  I can run xmaxima in the foreground from a terminal window and kill it with
Ctrl-C without killing the X session.
Comment 3 Andre Robatino 2005-09-09 08:33:54 EDT
  Sorry, this appears to be a duplicate of bug #167786 (the fact that maxima
isn't listed in Bugzilla, that is).
Comment 4 Rex Dieter 2005-09-09 09:27:11 EDT
Andre, 

In general, no single application should be able to take down an X session.    
 Further, xmaxima doesn't kill X (for me) when run on RH9, RHEL4, Fedora Core 3. 

However, I can confirm the crash on FC4, my ~/.xsession-errors (appended at the
end) is mostly unhelpful.  Considering that xmaxima is simply a wish(tk) script,
I'd venture this to be either a tk/tcl or X server bug, specific to Fedora Core 4.

---------------

  i i i i i i i       ooooo    o        ooooooo   ooooo   ooooo
  I I I I I I I      8     8   8           8     8     o  8    8
  I  \ `+' /  I      8         8           8     8        8    8
   \  `-+-'  /       8         8           8      ooooo   8oooo
    `-__|__-'        8         8           8           8  8
        |            8     o   8           8     o     8  8
  ------+------       ooooo    8oooooo  ooo8ooo   ooooo   8

Copyright (c) Bruno Haible, Michael Stoll 1992, 1993
Copyright (c) Bruno Haible, Marcus Daniels 1994-1997
Copyright (c) Bruno Haible, Pierpaolo Bernardi, Sam Steingold 1998
Copyright (c) Bruno Haible, Sam Steingold 1999-2003
--------------------------------------------------------------

Maxima 5.9.1 http://maxima.sourceforge.net
Using Lisp CLISP 2.35 (2005-08-29)
Distributed under the GNU Public License. See the file COPYING.
Dedicated to the memory of William Schelter.
This is a development version of Maxima. The function bug_report()
provides bug reporting information.
(%i1) kicker: sighandler called
*** kdesktop got signal 15 (Exiting)
end from FAM server connection
X connection to :0.0 broken (explicit kill or server shutdown).
Comment 5 Alex Lancaster 2005-09-09 09:30:06 EDT
Andre, could you close this bug and mark it as duplicate of bug #167786?

As for the killing X problem, yes I can also confirm and it is probably an
upstream problem because I also had the same problem (before the FC4 packages
were created) when I "rolled my own" RPMs from the SRPMs that were supplied at
http://maxima.sourceforge.net/download.shtml

I was kinda hoping that the problem went away with the new FC4 packages.
Comment 6 Andre Robatino 2005-09-09 21:39:16 EDT
  Closing as a duplicate of bug #167786.

*** This bug has been marked as a duplicate of 167786 ***
Comment 7 Alex Lancaster 2005-09-16 02:47:12 EDT
Bugzilla component "maxima" has now been created, and a new bug on the X
crashing problem has been opened at: bug #168451
Comment 8 Kevin Kofler 2005-09-22 06:18:43 EDT
*** Bug 168071 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.