Bug 167957 - gnome-themes-2.12.0-1 complain about theme index
Summary: gnome-themes-2.12.0-1 complain about theme index
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: redhat-artwork   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Matthias Clasen
QA Contact:
URL:
Whiteboard:
Keywords:
: 168011 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-09-09 21:11 UTC by Michal Jaegermann
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-12 14:41:10 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Michal Jaegermann 2005-09-09 21:11:26 UTC
Description of problem:

An update to 2.12.0-1 ends up with the following messages:

No theme index file in '/usr/share/icons/Bluecurve-inverse'.
If you really want to create an icon cache here, use --ignore-theme-index.

Obviously from postinstall scriptlet which runs
'/usr/bin/gtk-update-icon-cache --quiet ...'.  It looks that '--quiet'
is not good enough.  Should this theme index be present?

Version-Release number of selected component (if applicable):
gnome-themes-2.12.0-1

Comment 1 Michal Jaegermann 2005-10-01 20:02:35 UTC
With a freshly installed gnome-themes-2.12.0-2 and redhat-artwork-0.128-2,
which owns '/usr/share/icons/Bluecurve-inverse', I see exactly the same
complaint as above.  So in what sense this is "CLOSED RAWHIDE"?

Comment 2 Matthias Clasen 2005-10-02 03:54:15 UTC
In the sense that I fixed the problem in redhat-artwork, but overlooked that the
same issue occurs in the gnome-icon-theme %post. Should be fixed tomorrow.

Comment 3 Michal Jaegermann 2005-10-08 19:54:42 UTC
> Should be fixed tomorrow.
Hm, I just installed new gnome-themes-2.12.1-1 with 2005-10-05 build date
and I see the same complaints as originally reported.  Actually no; looking
closer there is also something new, i.e. '... /icons/locolor', in that:

No theme index file in '/usr/share/icons/Bluecurve-inverse'.
If you really want to create an icon cache here, use --ignore-theme-index.
No theme index file in '/usr/share/icons/locolor'.
If you really want to create an icon cache here, use --ignore-theme-index.

If that should be truly ignored then maybe 

                    ... >/dev/null 2>&1 || :

in %post is good enough?

Moreover "file /usr/share/icons/locolor is not owned by any package".
A leftover from some package (redhat-artwork?) which did install that in the
past but did not bother to admit an ownership?  Everying in this directory
is "not owned by any package".

Comment 4 Matthias Clasen 2005-10-12 05:18:36 UTC
*** Bug 168011 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.