Bug 1679893 - [RHEL8Beta] Install Problem when BTRFS signature is found on any partition
Summary: [RHEL8Beta] Install Problem when BTRFS signature is found on any partition
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: anaconda
Version: 8.0
Hardware: All
OS: Linux
unspecified
medium
Target Milestone: rc
: 8.3
Assignee: Anaconda Maintenance Team
QA Contact: Release Test Team
Alexandra Nikandrova
URL:
Whiteboard:
: 1676403 (view as bug list)
Depends On:
Blocks: 1660905 1776265 1676403 1676913
TreeView+ depends on / blocked
 
Reported: 2019-02-22 07:46 UTC by zkktuwien
Modified: 2020-11-04 03:24 UTC (History)
10 users (show)

Fixed In Version: anaconda-33.16.3.1-2
Doc Type: Bug Fix
Doc Text:
.Anaconda successfully finishes the installation without `btrfs-progs` package Previously, anaconda tried to install the `btrfs-progs` package if it detected a Btrfs device. However, there was no such package in the RHEL 8 repository. As a consequence, anaconda showed a dialog with a warning message about a missing package during the installation. With this update, anaconda does not try to install the `btrfs-progs` package, and the installation finishes successfully without showing a warning message about the missing `btrfs-progs` package.
Clone Of:
Environment:
Last Closed: 2020-11-04 03:22:50 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)
Anaconda error (50.25 KB, image/jpeg)
2019-02-22 07:46 UTC, zkktuwien
no flags Details
Sample BTRFS Signature (3.84 KB, application/octet-stream)
2019-02-22 07:48 UTC, zkktuwien
no flags Details
logs (1.23 MB, application/octet-stream)
2020-04-20 10:12 UTC, IBM Bug Proxy
no flags Details
screenshot (7.91 KB, application/octet-stream)
2020-04-20 10:12 UTC, IBM Bug Proxy
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 1676403 1 None None None 2021-01-20 06:05:38 UTC
Red Hat Product Errata RHBA-2020:4729 0 None None None 2020-11-04 03:23:13 UTC

Internal Links: 1676403

Description zkktuwien 2019-02-22 07:46:02 UTC
Created attachment 1537366 [details]
Anaconda error

Description of problem:

During installation on a host which has a BTRFS filesystem on any disk not used by this very installation, the BTRFS signature is detected and btrfs-progs is added as package requirement. But it does not exist in RHEL 8.

Version-Release number of selected component (if applicable):

RHEL 8 Beta

How reproducible:

Install RHEL 8 Beta on a host that has a BTRFS signature on any unused filesystem. I will attach a small signature for testing below.

Actual results:

Anaconda will complain that btrfs-progs is missing, see screenshot "Anaconda error".

Expected results:

It should just ignore any BTRFS filesystems.

Additional info:

anaconda.log contains:
08:19:27,922 DBG payload: added package requirement 'btrfs-progs' for storage, strong=True

Comment 1 zkktuwien 2019-02-22 07:48:43 UTC
Created attachment 1537367 [details]
Sample BTRFS Signature

This signature can be used to create a testcase without the need of a running version of btrfs-progs.

Comment 2 Jiri Konecny 2019-02-22 09:23:17 UTC
This is a duplicate of bug 1676403.

However, I won't close this bug because you don't have access to the original bug report.

Comment 5 Radek Vykydal 2020-03-31 14:54:25 UTC
This should be fixed by rebase to upstream where the issue was fixed in https://github.com/rhinstaller/anaconda/pull/2322.

Comment 6 Jan Stodola 2020-04-20 09:25:43 UTC
*** Bug 1676403 has been marked as a duplicate of this bug. ***

Comment 7 IBM Bug Proxy 2020-04-20 10:12:49 UTC
------- Comment From sthoufee@in.ibm.com 2019-03-28 07:31 EDT-------
Any update on this issue

------- Comment From sthoufee@in.ibm.com 2019-06-04 06:36 EDT-------
Redhat, Any update on this issue ?

------- Comment From sthoufee@in.ibm.com 2019-06-12 02:52 EDT-------
Redhat, Any update on this issue ?

------- Comment From seg@us.ibm.com 2019-10-29 18:22 EDT-------
Forget it.  If this is still a problem with RHEL 8.1, it can be fixed in RHEL 8.2.

Comment 8 IBM Bug Proxy 2020-04-20 10:12:53 UTC
Created attachment 1680220 [details]
logs

Comment 9 IBM Bug Proxy 2020-04-20 10:12:55 UTC
Created attachment 1680221 [details]
screenshot

Comment 10 Jiri Konecny 2020-04-21 14:46:49 UTC
Hello,

This is expected to be fixed by 8.3 release.

Comment 20 errata-xmlrpc 2020-11-04 03:22:50 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (anaconda bug fix and enhancement update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4729


Note You need to log in before you can comment on or make changes to this bug.