Bug 1679894 - [next_gen_installer] The version info for the master team's operator if not valid when describe clusteroperator
Summary: [next_gen_installer] The version info for the master team's operator if not v...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Master
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.1.0
Assignee: Michal Fojtik
QA Contact: zhou ying
URL:
Whiteboard:
Depends On: 1679871
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-02-22 07:58 UTC by zhou ying
Modified: 2019-06-04 10:44 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1679871
Environment:
Last Closed: 2019-06-04 10:44:19 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:44:27 UTC

Description zhou ying 2019-02-22 07:58:23 UTC
+++ This bug was initially created as a clone of Bug #1679871 +++

Description of problem:
The version info operator in master team (openshift-apiserver,kube-apiserver,kube-controller-manager) is always "0.0.0_version_hyperkube" which is not valid and not meaningful


Version-Release number of selected component (if applicable):
4.0.0-0.nightly-2019-02-21-215247
registry.svc.ci.openshift.org/ocp/release@sha256:88a2287b44f1ccff9d89d32d2fdf454925bb6fa4f572bffefac7667b41e6dca2

How reproducible:
always

Steps to Reproduce:
1. [root@dhcp-140-138 Downloads]# oc describe clusteroperator kube-apiserver
Name:         kube-apiserver
Namespace:    
Labels:       <none>
Annotations:  <none>
API Version:  config.openshift.io/v1
Kind:         ClusterOperator
Metadata:
  Creation Timestamp:  2019-02-22T04:01:18Z
  Generation:          1
  Resource Version:    87486
  Self Link:           /apis/config.openshift.io/v1/clusteroperators/kube-apiserver
  UID:                 81a7308a-3656-11e9-aa36-02fcd8d0ad28
Spec:
Status:
.....
  Versions:
    Name:     operator
    Version:  0.0.0_version_cluster-kube-apiserver-operator
    Name:     kube-apiserver
    Version:  0.0.0_version_hypershift
Events:       <none>


[root@dhcp-140-138 Downloads]# oc describe clusteroperator kube-controller-manager
Name:         kube-controller-manager
Namespace:    
Labels:       <none>
Annotations:  <none>
API Version:  config.openshift.io/v1
Kind:         ClusterOperator
Metadata:
  Creation Timestamp:  2019-02-22T04:06:58Z
  Generation:          1
  Resource Version:    88322
  Self Link:           /apis/config.openshift.io/v1/clusteroperators/kube-controller-manager
  UID:                 4c931029-3657-11e9-8e78-0aea814c5a8c
Spec:
Status:
......
  Versions:
    Name:     operator
    Version:  0.0.0_version_cluster-kube-controller-manager-operator
    Name:     kube-controller-manager
    Version:  0.0.0_version_hyperkube
Events:       <none>


[root@dhcp-140-138 Downloads]# oc describe clusteroperator openshift-apiserver
Name:         openshift-apiserver
Namespace:    
Labels:       <none>
Annotations:  <none>
API Version:  config.openshift.io/v1
Kind:         ClusterOperator
Metadata:
  Creation Timestamp:  2019-02-22T04:13:04Z
  Generation:          1
  Resource Version:    86720
  Self Link:           /apis/config.openshift.io/v1/clusteroperators/openshift-apiserver
  UID:                 26e2a38f-3658-11e9-a124-0aea814c5a8c
Spec:
Status:
 .....
  Versions:
    Name:     operator
    Version:  0.0.0_version_cluster-openshift-apiserver-operator
    Name:     openshift-apiserver
    Version:  0.0.0_version_hypershift
Events:       <none>


Actual results:
The version info : "0.0.0_version_hyperkube" is not valid and not meaningful

Expected results:
should have valid version info.

Comment 5 Michal Fojtik 2019-03-12 10:25:27 UTC
The PR merged.

Comment 7 zhou ying 2019-03-14 07:24:53 UTC
The issue has fixed:
[zhouying@dhcp-140-138 Downloads]$  oc version --short
Client Version: v4.0.22
Server Version: v1.12.4+4836bc9


[zhouying@dhcp-140-138 Downloads]$  oc describe clusteroperator kube-apiserver
Name:         kube-apiserver
Namespace:    
Labels:       <none>
Annotations:  <none>
API Version:  config.openshift.io/v1
Kind:         ClusterOperator
Metadata:
  Creation Timestamp:  2019-03-14T03:33:17Z
  Generation:          1
  Resource Version:    146781
  Self Link:           /apis/config.openshift.io/v1/clusteroperators/kube-apiserver
  UID:                 e83e6ce3-4609-11e9-a53a-0685e1bd5cfa
Spec:
Status:
  Conditions:
    Last Transition Time:  2019-03-14T07:03:15Z
    Reason:                AsExpected
    Status:                False
    Type:                  Failing
    Last Transition Time:  2019-03-14T07:04:45Z
    Message:               Progressing: 3 nodes are at revision 8
    Reason:                AsExpected
    Status:                False
    Type:                  Progressing
    Last Transition Time:  2019-03-14T03:33:17Z
    Message:               Available: 3 nodes are active; 3 nodes are at revision 8
    Reason:                AsExpected
    Status:                True
    Type:                  Available
    Last Transition Time:  2019-03-14T03:33:17Z
    Reason:                NoData
    Status:                Unknown
    Type:                  Upgradeable
  Extension:               <nil>
  Related Objects:
    Group:     operator.openshift.io
    Name:      cluster
    Resource:  kubeapiservers
    Group:     
    Name:      openshift-config
    Resource:  namespaces
    Group:     
    Name:      openshift-config-managed
    Resource:  namespaces
    Group:     
    Name:      openshift-kube-apiserver-operator
    Resource:  namespaces
    Group:     
    Name:      openshift-kube-apiserver
    Resource:  namespaces
  Versions:
    Name:     kube-apiserver
    Version:  1.12.4
    Name:     operator
    Version:  4.0.0-0.nightly-2019-03-13-233958
Events:       <none>
[zhouying@dhcp-140-138 Downloads]$ oc describe clusteroperator kube-controller-manager
Name:         kube-controller-manager
Namespace:    
Labels:       <none>
Annotations:  <none>
API Version:  config.openshift.io/v1
Kind:         ClusterOperator
Metadata:
  Creation Timestamp:  2019-03-14T03:26:28Z
  Generation:          1
  Resource Version:    87325
  Self Link:           /apis/config.openshift.io/v1/clusteroperators/kube-controller-manager
  UID:                 f47863c4-4608-11e9-81e5-067a3eea0c54
Spec:
Status:
  Conditions:
    Last Transition Time:  2019-03-14T05:28:58Z
    Reason:                AsExpected
    Status:                False
    Type:                  Failing
    Last Transition Time:  2019-03-14T05:29:16Z
    Message:               Progressing: 3 nodes are at revision 7
    Reason:                AsExpected
    Status:                False
    Type:                  Progressing
    Last Transition Time:  2019-03-14T03:28:33Z
    Message:               Available: 3 nodes are active; 3 nodes are at revision 7
    Reason:                AsExpected
    Status:                True
    Type:                  Available
    Last Transition Time:  2019-03-14T03:26:28Z
    Reason:                NoData
    Status:                Unknown
    Type:                  Upgradeable
  Extension:               <nil>
  Related Objects:
    Group:     operator.openshift.io
    Name:      cluster
    Resource:  kubecontrollermanagers
    Group:     
    Name:      openshift-config
    Resource:  namespaces
    Group:     
    Name:      openshift-config-managed
    Resource:  namespaces
    Group:     
    Name:      openshift-kube-controller-manager
    Resource:  namespaces
    Group:     
    Name:      openshift-kube-controller-manager-operator
    Resource:  namespaces
  Versions:
    Name:     operator
    Version:  4.0.0-0.nightly-2019-03-13-233958
    Name:     kube-controller-manager
    Version:  1.12.4
Events:       <none>

Comment 9 errata-xmlrpc 2019-06-04 10:44:19 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.