Bug 1679871 - [next_gen_installer]No version for openshift-controller-manager-operator when get clusteroperator
Summary: [next_gen_installer]No version for openshift-controller-manager-operator when...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Build
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.1.0
Assignee: Ben Parees
QA Contact: wewang
URL:
Whiteboard:
: 1667360 (view as bug list)
Depends On:
Blocks: 1679894
TreeView+ depends on / blocked
 
Reported: 2019-02-22 05:39 UTC by wewang
Modified: 2019-06-04 10:44 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
: 1679894 (view as bug list)
Environment:
Last Closed: 2019-06-04 10:44:19 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:44:27 UTC

Description wewang 2019-02-22 05:39:22 UTC
Description of problem:
No version for openshift-controller-manager-operator when get clusteroperator

Version-Release number of selected component (if applicable):
4.0.0-0.nightly-2019-02-21-215247
registry.svc.ci.openshift.org/ocp/release@sha256:88a2287b44f1ccff9d89d32d2fdf454925bb6fa4f572bffefac7667b41e6dca2

How reproducible:
always

Steps to Reproduce:
$ oc describe clusteroperator openshift-controller-manager
Name:         openshift-controller-manager
Namespace:    
Labels:       <none>
Annotations:  <none>
API Version:  config.openshift.io/v1
Kind:         ClusterOperator
Metadata:
  Creation Timestamp:  2019-02-22T02:39:05Z
  Generation:          1
  Resource Version:    12148
  Self Link:           /apis/config.openshift.io/v1/clusteroperators/openshift-controller-manager
  UID:                 0575c150-364b-11e9-94e8-0615dd2afa9e
Spec:
Status:
  Conditions:
    Last Transition Time:  2019-02-22T02:39:05Z
    Status:                False
    Type:                  Failing
    Last Transition Time:  2019-02-22T02:39:38Z
    Status:                True
    Type:                  Available
    Last Transition Time:  2019-02-22T02:41:25Z
    Status:                False
    Type:                  Progressing
  Extension:               <nil>
  Related Objects:
  Versions:  <nil>                                  ### no vesions
Events:      <none>
2.
3.

Actual results:
no vesion for versions part

Expected results:
should have version for it.

Additional info:

Comment 1 wewang 2019-02-22 05:42:17 UTC
*** Bug 1667360 has been marked as a duplicate of this bug. ***

Comment 4 wewang 2019-03-12 08:34:45 UTC
Today We only  launch successful ocp version:4.0.0-0.nightly-2019-03-06-074438, but the pr is not include in the version, so verify it in origin first

versions:
version: 4.0.0-0.ci-2019-03-12-025430
payload: registry.svc.ci.openshift.org/ocp/release@sha256:da5cc2524c5b7a8b962a317c54d046dc9a1f07a98414f6f6b009c546b6936a4d

[wewang@Desktop Downloads]$ oc get clusteroperator |grep openshift-controller-manager
openshift-controller-manager          4.0.0-0.ci-2019-03-12-025430   True        False         False     14m

$ oc describe clusteroperator openshift-controller-manager
  Versions:
    Name:     operator
    Version:  4.0.0-0.ci-2019-03-12-025430
Events:       <none>

Comment 7 errata-xmlrpc 2019-06-04 10:44:19 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.