Bug 168035 - libtool requires gcc = 3.4.3, but 3.4.4-2.fc3 is installed
libtool requires gcc = 3.4.3, but 3.4.4-2.fc3 is installed
Status: CLOSED DUPLICATE of bug 164601
Product: Fedora
Classification: Fedora
Component: libtool (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Karsten Hopp
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-11 04:21 EDT by Rudy Eschauzier
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-11 04:54:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rudy Eschauzier 2005-09-11 04:21:06 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050720 Fedora/1.0.6-1.1.fc3 Firefox/1.0.6

Description of problem:
The package libtool requires gcc = 3.4.3, but FC3 is at 3.4.4-2

Bug shows when first upgrading through yum, and then running apt-get:

[root@sun ~]# apt-get check
Reading Package Lists... Done
Building Dependency Tree... Done
You might want to run `apt-get --fix-broken install' to correct these.
The following packages have unmet dependencies:
  libtool: Depends: gcc (= 3.4.3) but 3.4.4-2.fc3 is installed
E: Unmet dependencies. Try using --fix-broken.

[root@sun ~]# rpm -qi --requires libtool
Name        : libtool                      Relocations: (not relocatable)
Version     : 1.5.6                             Vendor: Red Hat, Inc.
Release     : 4.FC3.3                       Build Date: Mon 15 Aug 2005 05:18:40 ...
gcc = 3.4.3
libtool-libs = 1.5.6-4.FC3.3
...

[root@sun ~]# rpm -q gcc
gcc-3.4.4-2.fc3

Version-Release number of selected component (if applicable):
libtool-1.5.6-4.FC3.3

How reproducible:
Always

Steps to Reproduce:
1. Upgrade FC3 through yum
2. run apt-get check
  

Actual Results:  [root@sun ~]# apt-get check
Reading Package Lists... Done
Building Dependency Tree... Done
You might want to run `apt-get --fix-broken install' to correct these.
The following packages have unmet dependencies:
  libtool: Depends: gcc (= 3.4.3) but 3.4.4-2.fc3 is installed
E: Unmet dependencies. Try using --fix-broken.

Expected Results:  No dependency errors

Additional info:

apt-0.5.15cnc7-1
Comment 1 Warren Togami 2005-09-11 04:54:34 EDT
This is a bug in apt where it fails to properly handle virtual provides.  It
would be wrong to change the packages which are correct to workaround an apt bug.

*** This bug has been marked as a duplicate of 164601 ***

Note You need to log in before you can comment on or make changes to this bug.