Bug 164601 - libtool requires gcc 3.4.3
libtool requires gcc 3.4.3
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: libtool (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Karsten Hopp
:
: 166978 168035 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-07-29 01:31 EDT by Dennis Björklund
Modified: 2007-11-30 17:11 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-19 04:14:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dennis Björklund 2005-07-29 01:31:55 EDT
gcc 3.4.4 was released as an update for FC3 some days ago. The last released
libtool however requiers gcc = 3.4.3 (as seen if you do rpm -q libtool -R).

I don't know if this breaks anything and that the current libtool really need
3.4.3, I just noticed the package problem and wanted to report that.
Comment 1 Fernando Lopez-Lezcano 2005-08-08 20:17:05 EDT
It is a problem even at the packaging level, if you upgrade the compiler the
resulting dependencies are broken and, for example, apt-get cannot be used to
install packages until the problem is fixed. 

Is there an fix for this being considered?
-- Fernando
Comment 2 Jeff Moe (jebba) 2005-08-14 00:18:47 EDT
ping. Usually libtool is recompiled when gcc is, but it wasn't this round... See
also #164774
Comment 3 Karsten Hopp 2005-08-15 11:24:14 EDT
Fixed package should show up in -testing soon. Please test and tell me if it
really fixes this issue so that I can move it to -final
Comment 4 TSS_Killer 2005-08-15 16:27:57 EDT
I can confirm that libtool works (since abiword depends on libtool, and it
installed successfully). 
Comment 5 Jeff Moe (jebba) 2005-08-15 17:22:11 EDT
The fixes in -testing (Aug 15) still require gcc 3.4.3 instead of 3.4.4.

$ rpm -qp -R libtool-1.5.6-4.FC3.3.i386.rpm  | grep gcc
gcc = 3.4.3

The most recent gcc update is 3.4.4:
$ rpm -qi gcc
Name        : gcc                          Relocations: (not relocatable)
Version     : 3.4.4                             Vendor: Red Hat, Inc.
Release     : 2.fc3                         Build Date: Fri 22 Jul 2005 07:12:03
AM MDT
Build Host: tweety.build.redhat.com
Group       : Development/Languages         Source RPM: gcc-3.4.4-2.fc3.src.rpm
Size        : 12904777                         License: GPL
Signature   : DSA/SHA1, Wed 27 Jul 2005 09:52:15 AM MDT, Key ID b44269d04f2a6fd2

==================================

FWIW, i believe the abiword package mentioned in comment #4 is direct from
abiword.com, not the FC build. The FC build doesn't require libtool.
Comment 6 Jakub Jelinek 2005-08-16 04:46:47 EDT
This update is completely unnecessary.  gcc-3.4.4 has hacks which make it
provide both 3.4.3 and 3.4.4 directories (designed originally for RHEL4).
So libtool can keep its old requirement and it ought to work just fine.
Comment 7 Frank Schmitt 2005-08-16 05:02:37 EDT
But this breaks fedora Core 3 for all apt users since those hacks seem not to
work with apt.
Comment 8 Dennis Björklund 2005-08-16 07:11:50 EDT
Yes, the problem is that libtool requiers gcc=3.4.3 in the rpm header, and that
package is not installed anymore. When you run apt-get you run into this:

The following packages have unmet dependencies:
  libtool: Depends: gcc (= 3.4.3) but 3.4.4-2.fc3 is installed

Of course one can downgrade gcc again if one want to use apt-get, but it still
looks like a bug in the libtool rpm to me.
Comment 9 Fernando Lopez-Lezcano 2005-08-16 12:34:02 EDT
The update is necessary. Currently the dependency tree of Fedora Core 3
including the officially released Updates is broken and needs to be fixed.
Downgrading gcc is not really a good option, fixing libtool's dependencies is
the right thing to do. 

I would imagine there would be a tool that checks dependencies for the whole
distro before updates are released? 
Comment 10 Jeff Moe (jebba) 2005-08-18 00:22:09 EDT
The released version has the same problem I reported in comment #5.
Comment 11 Warren Togami 2005-08-19 04:14:43 EDT
[wtogami@devserv i386]$ rpm -qp gcc-3.4.4-2.fc3.i386.rpm --provides
gcc = 3.4.3-26
gcc34
gcc = 3.4.4-2.fc3
[wtogami@devserv i386]$ rpm -qp --requires libtool-1.5.6-4.FC3.2.i386.rpm  |grep gcc
gcc = 3.4.3

These are the latest gcc and libtool in FC3 updates.  They clearly match
dependencies, as you can see if you install them manually with rpm.  This is an
apt bug where it is failing to see both gcc versions provided by gcc.  It is
seeing on the newest version.  apt has several other problems handling virtual
provide dependencies like this.

I used to be a big apt proponent, but now that upstream has given up and key
capabilities like multilib will never happen, I now consider apt to be a
dead-end.  Please stop using it if you want a fully working system in Fedora.
Comment 12 Fernando Lopez-Lezcano 2005-08-19 20:18:23 EDT
Thanks Warren for the details... too bad...

Still, it would be nice if compatibility could be maintained with apt (which is
also part of fedora extras - no, this is not a request for it to be erased from
extras :-)

As I now know this is not a problem with libtool compatibility I'll have to
release a fixed (yes, I know it is not strictly "broken") package so that apt
continues to work unaffected in Planet CCRMA (what I maintain). A complete
change over to yum is not yet an option. 

(BTW, yum ~= apt; ? ~= synaptic)
Comment 13 Warren Togami 2005-08-19 20:31:23 EDT
Sorry, it would be wrong to push an update only to workaround a buggy client
that upstream development even gave up on.  The correct course of action would
be to fix these bugs in apt, or move on to one of the better supported new software.

http://smartpm.org/
Conectiva^WMandriva has moved on to a total rewrite called smartpm, which has a
GUI interface too.  smartpm has a key advantage over apt or yum in that it can
use any existing RPM repository, not limited to just apt or yum.

yum has two different GUI interfaces currently in Fedora Extras called kyum and
yumex.  Both are considered to be not so great.  We hope to write a FC included
yum GUI interface called pup for FC5.
Comment 14 Fernando Lopez-Lezcano 2005-08-19 20:46:47 EDT
I know it is not the best choice, but it is the only course of action that I
currently have given the resources I have available. I can't debug apt and I
can't switch to yum, so it is the proverbial "between a rock and a hard place".
Not that many users have run into this problem but when they do I don't have a
solution (other than say use yum, of course). 
Comment 15 Karsten Hopp 2005-08-29 09:30:31 EDT
*** Bug 166978 has been marked as a duplicate of this bug. ***
Comment 16 Tony 2005-08-30 06:27:06 EDT
This non bug applies to all package managers that check dependencies (which is 
all of them) so Up2Date, apt, and synaptic will not install Libtool (I haven't 
tried yum but I suspect it won't either) and I want to install it because 
Kdevelop needs it.
So is it going to be fixed and when. Sorry to be a nag.
Comment 17 Dennis Björklund 2005-08-30 08:26:41 EDT
I stoped using apt-get because of this and changed to yum, and it doesn't
complain about the dependency. I don't know if it would have installed libtool
by itself but at least it doesn't complain now after it is installed (as apt-get
did).

As Warren Togami pointed out, gcc provides both versions so the dependency check
should not fail.
Comment 18 Gregory Haase 2005-09-02 13:22:23 EDT
I've had this probably for about a month now using yum on FC3. I haven't tried
any other package managers.

If I run yum update, I get:

--> Processing Dependency: gcc = 3.4.2 for package: libtool
--> Finished Dependency Resolution
Error: Missing Dependency: gcc = 3.4.2 is needed by package libtool

If I run yum update gcc.i386, I get:

Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package gcc.i386 0:3.4.4-2.fc3 set to be updated
--> Running transaction check
--> Processing Dependency: gcc = 3.4.2 for package: libtool
--> Processing Dependency: gcc = 3.4.3-22.fc3 for package: gcc-c++
--> Processing Dependency: gcc = 3.4.3-22.fc3 for package: gcc-g77
--> Processing Dependency: gcc = 3.4.3-22.fc3 for package: gcc-java
--> Processing Dependency: libgcc >= 3.4.4-2.fc3 for package: gcc
--> Processing Dependency: gcc = 3.4.3-22.fc3 for package: gcc-objc
--> Processing Dependency: cpp = 3.4.4-2.fc3 for package: gcc
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package cpp.i386 0:3.4.4-2.fc3 set to be updated
---> Package libgcc.i386 0:3.4.4-2.fc3 set to be updated
---> Package gcc-g77.i386 0:3.4.4-2.fc3 set to be updated
---> Package gcc-c++.i386 0:3.4.4-2.fc3 set to be updated
---> Package gcc-objc.i386 0:3.4.4-2.fc3 set to be updated
---> Package gcc-java.i386 0:3.4.4-2.fc3 set to be updated
--> Running transaction check
--> Processing Dependency: gcc = 3.4.2 for package: libtool
--> Processing Dependency: libobjc = 3.4.4-2.fc3 for package: gcc-objc
--> Processing Dependency: libstdc++-devel = 3.4.4 for package: gcc-c++
--> Processing Dependency: libstdc++ = 3.4.4 for package: gcc-c++
--> Processing Dependency: libf2c = 3.4.4-2.fc3 for package: gcc-g77
--> Processing Dependency: libgcj-devel >= 3.4.4 for package: gcc-java
--> Processing Dependency: libgcj >= 3.4.4 for package: gcc-java
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package libgcj.i386 0:3.4.4-2.fc3 set to be updated
---> Package libf2c.i386 0:3.4.4-2.fc3 set to be updated
---> Package libstdc++-devel.i386 0:3.4.4-2.fc3 set to be updated
---> Package libobjc.i386 0:3.4.4-2.fc3 set to be updated
---> Package libstdc++.i386 0:3.4.4-2.fc3 set to be updated
---> Package libgcj-devel.i386 0:3.4.4-2.fc3 set to be updated
--> Running transaction check
--> Processing Dependency: gcc = 3.4.2 for package: libtool
--> Finished Dependency Resolution
Error: Missing Dependency: gcc = 3.4.2 is needed by package libtool



Curiously enough, I don't even have gcc 3.4.2 installed I have 3.4.3:

# gcc --version
gcc (GCC) 3.4.3 20050227 (Red Hat 3.4.3-22.fc3)
Comment 19 Tony 2005-09-03 21:03:01 EDT
Re #17. You're right, yum installed it with no compliants. Synaptic complains 
that I now have a broken package but I can live with that.
Comment 20 Warren Togami 2005-09-11 04:54:36 EDT
*** Bug 168035 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.