Bug 168047 - desktop-file-utils doesn't build without emacs
desktop-file-utils doesn't build without emacs
Status: CLOSED DUPLICATE of bug 141297
Product: Fedora
Classification: Fedora
Component: desktop-file-utils (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
: Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-11 12:21 EDT by Roozbeh Pournader
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-12 10:22:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to add the build requirement (272 bytes, patch)
2005-09-11 12:25 EDT, Roozbeh Pournader
no flags Details | Diff

  None (edit)
Description Roozbeh Pournader 2005-09-11 12:21:58 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050602 Red Hat/1.7.8-0.90.1.legacy

Description of problem:
desktop-file-utils-0.10-1.src.rpm would not build without having emacs installed, but doesn't mention that emacs is required to build the package.


Version-Release number of selected component (if applicable):
desktop-file-utils-0.10-1

How reproducible:
Always

Steps to Reproduce:
1. Start with an emacs-less machine, or uninstall emacs ('yum remove emacs')
2. rpm -ivh desktop-file-utils-0.10-1.src.rpm
3. cd rpmbuild/SPECS (or wherever the spec files are)
4. rpmbuild -ba desktop-file-utils.spec


Actual Results:  The build process start and fails after a while with a hard to decipher error message, ending in:

error: File not found: /var/tmp/desktop-file-utils-root/usr/share/emacs/site-lisp


Expected Results:  It should fail with a clear error message mentioning the requirement of emacs to build the package.

Additional info:
Comment 1 Roozbeh Pournader 2005-09-11 12:25:35 EDT
Created attachment 118693 [details]
patch to add the build requirement

Attached a patch to add the build requirement.
Comment 2 Ray Strode [halfline] 2005-09-12 10:22:55 EDT
Hi Roozbeh,

This is already fixed in Rawhide.  It doesn't seem like a good candidate for a
FC4 update, though. Rawhide and FC-4 currently ship the same version of
desktop-file-utils.



*** This bug has been marked as a duplicate of 141297 ***

Note You need to log in before you can comment on or make changes to this bug.