Bug 168107 - import of rhpl.ethtool fails, breaking up2date in hardware.py
import of rhpl.ethtool fails, breaking up2date in hardware.py
Status: CLOSED DUPLICATE of bug 168017
Product: Fedora
Classification: Fedora
Component: rhpl (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-12 10:52 EDT by Nalin Dahyabhai
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-12 11:47:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nalin Dahyabhai 2005-09-12 10:52:53 EDT
Description of problem:
The latest rhpl includes a reference to an undefined symbol (iw_pr_ether) in the
ethtool module, so importing it fails.  By the looks of it, it's a function
which libiw would be expected to provide, but libiw provides no such function.

Version-Release number of selected component (if applicable):
rhpl-0.170-1

How reproducible:
Always

Steps to Reproduce:
1. python -c "import rhpl.ethtool"
  
Actual results:
ImportError: /usr/lib/python2.4/site-packages/rhpl/ethtool.so: undefined symbol:
iw_pr_ether

Expected results:
(no output)
Comment 1 Jeremy Katz 2005-09-12 11:47:25 EDT

*** This bug has been marked as a duplicate of 168017 ***

Note You need to log in before you can comment on or make changes to this bug.