Bug 168119 - Interoperability problem with Python 2.4
Interoperability problem with Python 2.4
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: Pyrex (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: John (J5) Palmieri
:
: 169670 (view as bug list)
Depends On:
Blocks: 169147
  Show dependency treegraph
 
Reported: 2005-09-12 13:33 EDT by Giovanni Bajo
Modified: 2013-03-13 00:48 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-13 17:42:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Giovanni Bajo 2005-09-12 13:33:00 EDT
Description of problem:
When using Pyrex to build anything with Python 2.4, I get an exception. This is 
because the prototype of swig_sources changed between Python 2.3 and Python 
2.4, and Pyrex re-implements it.

Version-Release number of selected component (if applicable):
0.9.3

How reproducible:
Every time.

Steps to Reproduce:
1. "python setup.py build_ext" with any Pyrex extension.
  
Actual results:
Traceback (most recent call last):
  File "setup.py", line 10, in ?
    cmdclass = {'build_ext': build_ext}
  File "/usr/lib/python2.4/distutils/core.py", line 149, in setup
    dist.run_commands()
  File "/usr/lib/python2.4/distutils/dist.py", line 946, in run_commands
    self.run_command(cmd)
  File "/usr/lib/python2.4/distutils/dist.py", line 966, in run_command
    cmd_obj.run()
  File "/usr/lib/python2.4/distutils/command/build_ext.py", line 279, in run
    self.build_extensions()
  File "/usr/lib/python2.4/distutils/command/build_ext.py", line 405, in 
build_extensions
    self.build_extension(ext)
  File "/usr/lib/python2.4/distutils/command/build_ext.py", line 442, in 
build_extension
    sources = self.swig_sources(sources, ext)
TypeError: swig_sources() takes exactly 2 arguments (3 given)


Expected results:
The extension should have been created.

Additional info:
This patch seems to fix the problem for me:
http://www.develer.com/~rasky/pyrex093-py24-fix.patch
Comment 1 Dave Malcolm 2005-09-30 17:02:04 EDT
*** Bug 169670 has been marked as a duplicate of this bug. ***
Comment 2 John (J5) Palmieri 2005-09-30 17:29:43 EDT
arg, I submitted the dup to the release so I will have to close this manually
once the fix is pushed.  The updated patch is queued to be pushed by the release
team.
Comment 3 Rahul Sundaram 2005-11-24 15:23:43 EST
has this been fixed now?
Comment 4 Dave Malcolm 2006-01-13 17:42:32 EST
Looks like it was fixed in upstream 0.9.3.1, which is in rawhide; closing.

Note You need to log in before you can comment on or make changes to this bug.