Bug 168157 - Please build and ship ppc64 gdb
Please build and ship ppc64 gdb
Status: CLOSED DUPLICATE of bug 205976
Product: Fedora
Classification: Fedora
Component: gdb (Show other bugs)
4
powerpc Linux
medium Severity medium
: ---
: ---
Assigned To: Alexandre Oliva
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-12 20:05 EDT by Richard Henderson
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-30 04:48:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Richard Henderson 2005-09-12 20:05:46 EDT
The shipped gdb executable with FC4 can only debug ppc32 executables.

Even if one forcibly enables ppc64 support in bfd etc, a 32-bit gdb
executable has problems debugging 64-bit targets.  This can partially
be fixed by rewriting bits of code to use PPC_PTRACE_*_3264, but that
on its own does not (for some reason) fix the whole problem.  All of
this can be fixed, if one cares enough.

On the other hand, building a 64-bit gdb executable appears to 
successfully debug both 64 and 32-bit executables.  It seems like 
simply building another rpm is the easiest short-term way around
this problem.
Comment 1 Jan Kratochvil 2006-09-30 04:48:07 EDT

*** This bug has been marked as a duplicate of 205976 ***

Note You need to log in before you can comment on or make changes to this bug.