Bug 205976 - Missing gdb.ppc64 build (while gdb.ppc exists)
Summary: Missing gdb.ppc64 build (while gdb.ppc exists)
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: distribution (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: ppc64 Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Bill Nottingham
URL:
Whiteboard:
Keywords:
: 168157 205333 (view as bug list)
Depends On: 205235
Blocks: 205333 206488
TreeView+ depends on / blocked
 
Reported: 2006-09-11 03:53 UTC by Jan Kratochvil
Modified: 2014-03-17 03:02 UTC (History)
6 users (show)

Fixed In Version: gdb-6.5-8.fc6.ppc64
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-30 09:05:01 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jan Kratochvil 2006-09-11 03:53:09 UTC
Description of problem:
gdb.ppc64 is missing in RawHide.ppc composition (Bug 205333).

Version-Release number of selected component (if applicable):
gdb-6.5-7.fc6.ppc.rpm

How reproducible:
Always.

Steps to Reproduce:
1. List
http://armstrong.rhts.boston.redhat.com/distros/rawhide-ppc/Fedora/RPMS/gdb-6.5-7.fc6.ppc64.rpm

Actual results:
No file found.

Expected results:
File should be found.

Additional info:

Comment 1 Jesse Keating 2006-09-11 11:51:27 UTC
As stated in the bug blocked by this, we can't really include this as multilib
as the ppc and ppc64 versions conflict with eachother.  In i386 / x86_64 land
this isn't a problem so much as each arch gets their own gdb.  But since we only
ship one ppc tree that is both ppc and ppc64 we can't do that here.

Comment 2 Jan Kratochvil 2006-09-11 12:08:14 UTC
As I consider gdb.ppc64 as essential component of RHEL.ppc64 it should be
resolved somehow. What to choose?

(1) You will handle conflicting "application-multilibs" as some new feature
    of anaconda/yum till FC6-GA.

(2) I should provide specific ppc64-conditional packaging in .spec to make
    gdb-6.5-X.ppc.rpm and gdb-6.5-X.ppc64.rpm non-conflicting
    (separate /usr/bin/gdb64 binary etc.).

(3) I should provide specific ppc64-conditional packaging in .spec to make
    gdb-6.5-X.ppc.rpm and gdb64-6.5-X.ppc64.rpm non-conflicting
    (separate /usr/bin/gdb64 binary etc.).
    Not sure if it gets installed by anaconda/yum appropriately, I hope so.


Comment 3 Jesse Keating 2006-09-11 12:16:30 UTC
How is it that gcc handles this?  Of course a better answer would be to stop
trying to do silly things by offering only one ppc variant, but I don't think we
can do that.  In RHEL5 land, the ppc tree may be from a standpoint of we support
only ppc64 machines, but 32 bit runs faster, so we could provide only the 64bit
gdb.  Can a ppc64 gdb debug 32bit applications?

Comment 4 Bill Nottingham 2006-09-11 14:35:05 UTC
Yes, AFAIK.

How do they conflict? If it's just /usr/bin/gdb, that should be handled fine by
the normal elf32/elf64 handling.

Comment 5 wzhou 2006-09-11 15:38:44 UTC
(In reply to comment #3)

> Can a ppc64 gdb debug 32bit applications?

Yes. ppc64 gdb can debug 32bit and 64bit application at the same time.  Both 
RHEL4 and FC5 for ppc/ppc64 shipped a 64bit gdb, which can debug both 32-bit 
and 64bit application.  I am not sure how these distribution build (and ship) 
it though. 

Comment 6 Jesse Keating 2006-09-11 15:46:14 UTC
I'm going to add gdb back to the "whitelist" of multilib packages.  Normal
handling should make this work.

Comment 7 Jan Kratochvil 2006-09-11 16:15:04 UTC
(In reply to comment #6)
> I'm going to add gdb back to the "whitelist" of multilib packages.  Normal
> handling should make this work.

OK, understood it is in fact enough.


Comment 8 Jan Kratochvil 2006-09-13 12:31:00 UTC
(In reply to comment #6)
> I'm going to add gdb back to the "whitelist" of multilib packages.

http://armstrong.rhts.boston.redhat.com/distros/rawhide-ppc/Fedora/RPMS/
with timestamps "13-Sep-2006 05:34" still does not contain "gdb-*.ppc64.rpm".
Should I wait more or it just still has not been done?


Comment 9 Jan Kratochvil 2006-09-30 08:48:22 UTC
*** Bug 168157 has been marked as a duplicate of this bug. ***

Comment 10 Jan Kratochvil 2006-09-30 08:49:36 UTC
*** Bug 205333 has been marked as a duplicate of this bug. ***

Comment 11 Jan Kratochvil 2006-09-30 09:05:01 UTC
Exists and it can debug itself:
http://armstrong.rhts.boston.redhat.com/distros/rawhide-ppc/Fedora/RPMS/gdb-6.5-8.fc6.ppc64.rpm
/usr/bin/gdb: ELF 64-bit MSB executable, cisco 7500, version 1 (SYSV), for
GNU/Linux 2.6.9, dynamically linked (uses shared libs), for GNU/Linux 2.6.9,
stripped



Note You need to log in before you can comment on or make changes to this bug.