Bug 1682978 - openshift-sti-build have no version infomation
Summary: openshift-sti-build have no version infomation
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Build
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.1.0
Assignee: Adam Kaplan
QA Contact: wewang
URL:
Whiteboard:
Depends On:
Blocks: 1657997
TreeView+ depends on / blocked
 
Reported: 2019-02-26 02:13 UTC by weiwei jiang
Modified: 2019-06-04 10:44 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-04 10:44:27 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:44:33 UTC

Description weiwei jiang 2019-02-26 02:13:58 UTC
Description of problem:
When trying to find the version about openshift-sti-build, got nothing

[core@ip-10-0-149-70 ~]$ oc debug pods/ruby-ex-1-build -n wjiangtest
Starting pod/ruby-ex-2-build-debug, command was: openshift-sti-build --loglevel=0
If you don't see a command prompt, try pressing enter.
sh-4.2# which openshift-sti-build
/usr/bin/openshift-sti-build
sh-4.2# ls -al /usr/bin/openshift-sti-build
lrwxrwxrwx. 1 root root 26 Feb 24 02:37 /usr/bin/openshift-sti-build -> /usr/bin/openshift-builder
sh-4.2# /usr/bin/openshift-sti-build version 
openshift-sti-build 

Version-Release number of selected component (if applicable):
4.0.0-0.nightly-2019-02-24-045124

How reproducible:
Always

Steps to Reproduce:
1. oc new-app centos/ruby-25-centos7~https://github.com/sclorg/ruby-ex.git 
2. oc debug pods/ruby-ex-1-build
3. openshift-sti-build version

Actual results:
sh-4.2# /usr/bin/openshift-sti-build version 
openshift-sti-build 

Expected results:
Should have something like v1.x.x

Additional info:

Comment 1 weiwei jiang 2019-02-26 02:14:42 UTC
if we can, better output with the buildah version also.

Comment 2 Adam Kaplan 2019-02-26 14:00:09 UTC
@weiwei we use buildah source code directly in openshift-sti-builder, so I don't think we will be able to produce a buildah version number.

Comment 3 weiwei jiang 2019-02-27 05:12:00 UTC
(In reply to Adam Kaplan from comment #2)
> @weiwei we use buildah source code directly in openshift-sti-builder, so I
> don't think we will be able to produce a buildah version number.

Got you, and actually when we are trying to verify bugs like this one https://bugzilla.redhat.com/show_bug.cgi?id=1657997 or draft some test reports,
we have to list all the detail version of each components for various reasons.

And in theory buildah version is not necessary for openshift-sti-build, so I say "better".

And I have no idea how oc can display kubernetes version info like the following:
[root@qe-wjiang310-mrre-1 ~]# oc version 
oc v3.10.118
kubernetes v1.10.0+b81c8f8
features: Basic-Auth GSSAPI Kerberos SPNEGO

Server https://qe-wjiang310-mrre-1:8443
openshift v3.10.118
kubernetes v1.10.0+b81c8f8

Anyway, openshift-sti-build version is enough to track the changes for each version, since buildah is embed in via source code level.

Comment 4 Adam Kaplan 2019-02-28 14:45:14 UTC
@weiwei FYI we're working through a version reporting process that can be reported across all Openshift components

Comment 5 Adam Kaplan 2019-03-01 18:58:23 UTC
PR in openshift/builder: https://github.com/openshift/builder/pull/47

Comment 6 wewang 2019-03-12 08:33:45 UTC
Today We only  launch successful ocp version:4.0.0-0.nightly-2019-03-06-074438, but the pr is not include in the version, so verify it in origin first

versions:
version: 4.0.0-0.ci-2019-03-12-025430
payload: registry.svc.ci.openshift.org/ocp/release@sha256:da5cc2524c5b7a8b962a317c54d046dc9a1f07a98414f6f6b009c546b6936a4d

[wewang@Desktop Downloads]$ oc get clusteroperator |grep openshift-controller-manager
openshift-controller-manager          4.0.0-0.ci-2019-03-12-025430   True        False         False     14m

$ oc describe clusteroperator openshift-controller-manager
  Versions:
    Name:     operator
    Version:  4.0.0-0.ci-2019-03-12-025430
Events:       <none>

Comment 7 wewang 2019-03-12 08:35:37 UTC
Sorry should add Comment 6 to bug1679871

Comment 8 weiwei jiang 2019-03-12 08:52:46 UTC
Checked on 4.0.0-0.nightly-2019-03-11-133421(Rejected)

[root@wjiang wjiang]# docker run -it $(oc adm release info registry.svc.ci.openshift.org/ocp/release:4.0.0-0.nightly-2019-03-11-133421 --image-for=docker-builder) /bin/bash
[root@57618d70ddde /]# openshift-sti-build version 
openshift-sti-build v4.0.22-1+875f97b-dirty


Since the version I checked is rejected, so need wait a Accepted version to have another check

Comment 10 weiwei jiang 2019-03-14 10:02:05 UTC
Checked with 4.0.0-0.nightly-2019-03-13-233958, and this issue has been fixed.

➜  ~ oc new-app centos/ruby-25-centos7~https://github.com/sclorg/ruby-ex.git        
--> Found Docker image c4310a5 (7 days old) from Docker Hub for "centos/ruby-25-centos7"                 
                                                                                                                  
    Ruby 2.5                                                                            
    --------                                                                        
    Ruby 2.5 available as container is a base platform for building and running various Ruby 2.5 applications and frameworks. Ruby is the interpreted scripting language for quick and easy object-oriented programming. It has many features to process text files and to do sy
stem management tasks (as in Perl). It is simple, straight-forward, and extensible.                                                                                  
                                     
    Tags: builder, ruby, ruby25, rh-ruby25                                           
                                                                
    * An image stream tag will be created as "ruby-25-centos7:latest" that will track the source image                                 
    * A source build using source code from https://github.com/sclorg/ruby-ex.git will be created          
      * The resulting image will be pushed to image stream tag "ruby-ex:latest"                                                                                                                                                                                                 
      * Every time "ruby-25-centos7:latest" changes a new build will be triggered                                                                                                                                                                                               
    * This image will be deployed in deployment config "ruby-ex"
    * Port 8080/tcp will be load balanced by service "ruby-ex"
      * Other containers can access this service through the hostname "ruby-ex"

--> Creating resources ...
    imagestream.image.openshift.io "ruby-25-centos7" created
    imagestream.image.openshift.io "ruby-ex" created
    buildconfig.build.openshift.io "ruby-ex" created
    deploymentconfig.apps.openshift.io "ruby-ex" created
    service "ruby-ex" created
--> Success
    Build scheduled, use 'oc logs -f bc/ruby-ex' to track its progress.
    Application is not exposed. You can expose services to the outside world by executing one or more of the commands below:
     'oc expose svc/ruby-ex'
    Run 'oc status' to view your app.


➜  ~ oc debug pod/ruby-ex-1-build
Starting pod/ruby-ex-1-build-debug, command was: openshift-sti-build --loglevel=0
If you don't see a command prompt, try pressing enter.
sh-4.2# openshift-sti-build version 
openshift-sti-build v4.0.22-201903131052+948279a-dirty

Comment 12 errata-xmlrpc 2019-06-04 10:44:27 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.