Bug 16832 - An /etc/fstab which anaconda processes incorrectly
Summary: An /etc/fstab which anaconda processes incorrectly
Status: CLOSED DUPLICATE of bug 17932
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda   
(Show other bugs)
Version: 6.2
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Michael Fulbright
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-08-23 22:50 UTC by Stephen Walton
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-09 19:47:52 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Stephen Walton 2000-08-23 22:50:24 UTC
I attempted an update of a RedHat 6.1 system containing two IDE disks (hda
and hdc) striped together as a RAID-0 and a single SCSI disk (sda)
containing the OS.  /etc/fstab contains:

/dev/sda7               /                       ext2    defaults        1 1
/dev/sda1               /boot                   ext2    defaults        1 2
/dev/sda5               swap                    swap    defaults        0 0
/dev/sda6               swap                    swap    defaults        0 0
/dev/fd0                /mnt/floppy             ext2    owner,noauto    0 0
/dev/cdrom              /cdrom                  iso9660 noauto,user     0 0
/dev/md0                /cfdt                   ext2    defaults        1 2
none                    /proc                   proc    defaults        0 0
none                    /dev/pts                devpts 
gid=5,mode=620       0 0

The update procedure failed in /usr/lib/anaconda/fstab.py line 705 while
processing the line beginning with /dev/md0.  I was able to complete the
update by commenting out this line before the update, but this should be
fixed, I'd think.

Comment 1 Michael Fulbright 2000-08-24 14:08:27 UTC
Please try to reproduce Brock.

May  be related to bug number 16833.

Comment 2 Stephen Walton 2000-08-24 21:48:20 UTC
As I noted under bug 16383, my RAID partitions are labeled as type 83, not
0xfd.  My mistake.  However, I'd think the entry for /dev/md0 in /etc/fstab
should not have caused anaconda to abort even in this case.


Comment 3 Michael Fulbright 2000-10-09 19:46:34 UTC
I think you mean bug 16833.

Comment 4 Michael Fulbright 2000-10-09 19:47:52 UTC
This is related to bug 17932, which is an enchancement request to handle this
situation more gracefully.


*** This bug has been marked as a duplicate of 17932 ***


Note You need to log in before you can comment on or make changes to this bug.