Bug 16833 - anaconda erroneously attempts mounts of RAID disks
Summary: anaconda erroneously attempts mounts of RAID disks
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda   
(Show other bugs)
Version: 6.2
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Michael Fulbright
QA Contact:
URL:
Whiteboard:
Keywords:
: 53859 54754 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-08-23 22:53 UTC by Stephen Walton
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-09-07 20:50:57 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Stephen Walton 2000-08-23 22:53:21 UTC
My Redhat 6.1 system contained two IDE disks, hda and hdc, set up as a
RAID-0 system, and a single SCSI disk with the OS on it.  While attempting
an update to RedHat 6.2, the installation procedure attempted to mount both
/dev/hda5 and /dev/hdc5 as normal ext2 file systems.  This failed, but in
the process the RAID system was marked as unclean, requiring a lengthy fsck
on first boot.  Fortunately no data were lost, but I doubt this can be
guaranteed.  I'd think the tool which attempts to mount a file system
should be changed so as to not to touch the disk if there is not a usable
ext2 file system on it.

Comment 1 Michael Fulbright 2000-08-24 14:05:09 UTC
What are the partition types for these partitions - they should be type 0xfd.

Also - are these partitions listed in your /etc/fstab? They should not be if
they are part of a RAID array.


Comment 2 Michael Fulbright 2000-08-24 14:08:49 UTC
May be related to bug number 16832.

Comment 3 Stephen Walton 2000-08-24 21:46:58 UTC
(hanging head in shame) No, the partitions aren't type 0xfd, they're type 83.  I
was _sure_ I'd set them to 0xfd when I created the RAID array, since I carefully
followed the instructions in the HOW-TO, but obviously I forgot a crucial "w" to
fdisk at some point.  /dev/hda and /dev/hdc are not listed in /etc/fstab,
though.

Will any harm be done if I unmount the filesystem, change the partition type on
both disks to 0xfd, and remount it?


Comment 4 Michael Fulbright 2000-09-07 20:50:55 UTC
I would backup your important data before changing the partition types. I think
it should work but don't hold me to that.

Comment 5 Brent Fox 2001-09-20 16:08:51 UTC
*** Bug 53859 has been marked as a duplicate of this bug. ***

Comment 6 Martin Pineault 2001-10-19 15:09:15 UTC
*** Bug 54754 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.