Bug 53859 - Anaconda mounts half of RAID-0 (!) then crashes
Summary: Anaconda mounts half of RAID-0 (!) then crashes
Status: CLOSED DUPLICATE of bug 16833
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
high
Target Milestone: ---
Assignee: Brent Fox
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-09-20 03:10 UTC by Andrew Pam
Modified: 2007-04-18 16:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-20 15:56:58 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Anaconda crash dump (10.33 KB, text/plain)
2001-09-20 03:11 UTC, Andrew Pam
no flags Details
/etc/fstab (1.16 KB, text/plain)
2001-09-20 03:12 UTC, Andrew Pam
no flags Details
/etc/raidtab (838 bytes, text/plain)
2001-09-20 03:12 UTC, Andrew Pam
no flags Details
Output of fdisk -l (1.22 KB, text/plain)
2001-09-20 15:56 UTC, Andrew Pam
no flags Details

Description Andrew Pam 2001-09-20 03:10:23 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.8i1 i586)

Description of problem:
On a system running RAID-0, when upgrading from RH7.0 to 7.1 Anaconda
detected a partition containing an unused /usr directory structure.  It
mounts HALF THE STRIPE as a regular ext2 filesystem despite the fstab and
raidtab and then crashes.  rm -rf on the unused partition did not solve the
problem, but dd if=/dev/zero bs=1M count=1 did.  :)

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.  Setup RAID-0 striped partitions.
2.  Discontinue use of a partition that had been used as /usr (switch to
another partition)
3.  Attempt a RedHat upgrade.
	

Actual Results:  Anaconda crashes.

Expected Results:  Install should proceed normally.

Additional info:

Comment 1 Andrew Pam 2001-09-20 03:11:36 UTC
Created attachment 32163 [details]
Anaconda crash dump

Comment 2 Andrew Pam 2001-09-20 03:12:25 UTC
Created attachment 32164 [details]
/etc/fstab

Comment 3 Andrew Pam 2001-09-20 03:12:57 UTC
Created attachment 32165 [details]
/etc/raidtab

Comment 4 Brent Fox 2001-09-20 15:22:35 UTC
Can you post the output of 'fdisk -l' on the drive(s) in question?

Comment 5 Andrew Pam 2001-09-20 15:56:54 UTC
Created attachment 32219 [details]
Output of fdisk -l

Comment 6 Brent Fox 2001-09-20 16:08:56 UTC
Ah.  Raid partitions should be of type 0xfd (Linux raid auto), not type 0x83
(Linux).  The installer will do strange things if the Raid partitions are of the
wrong type.  This is a dupe of bug #16833

*** This bug has been marked as a duplicate of 16833 ***


Note You need to log in before you can comment on or make changes to this bug.