Bug 1683746 - Include python-ovirt-engine-sdk4 downstream only package
Summary: Include python-ovirt-engine-sdk4 downstream only package
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-common
Version: 15.0 (Stein)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: beta
: 15.0 (Stein)
Assignee: Bob Fournier
QA Contact: Alexander Chuzhoy
URL:
Whiteboard:
: 1712542 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-02-27 17:30 UTC by Bob Fournier
Modified: 2019-09-26 10:48 UTC (History)
4 users (show)

Fixed In Version: openstack-tripleo-common-10.7.1-0.20190614200406.277902e.el8ost
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-09-21 11:20:27 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2019:2811 0 None None None 2019-09-21 11:20:55 UTC

Description Bob Fournier 2019-02-27 17:30:20 UTC
Description of problem:

Similar to https://code.engineering.redhat.com/gerrit/#/c/155247/ which was done for OSP-14, we should include python-ovirt-engine-sdk4 for OSP-15.

See https://bugzilla.redhat.com/show_bug.cgi?id=1646641

Comment 1 Bob Fournier 2019-05-21 20:49:38 UTC
*** Bug 1712542 has been marked as a duplicate of this bug. ***

Comment 3 Bob Fournier 2019-06-11 12:41:04 UTC
To verify this we an use test Sasha did here - https://bugzilla.redhat.com/show_bug.cgi?id=1712542.

Comment 5 Alexander Chuzhoy 2019-06-18 20:43:34 UTC
*** Bug 1721607 has been marked as a duplicate of this bug. ***

Comment 6 Alexander Chuzhoy 2019-06-18 20:44:29 UTC
FailedQA:

The details are here:
https://bugzilla.redhat.com/show_bug.cgi?id=1721607

Comment 7 Bob Fournier 2019-06-19 13:57:18 UTC
In latest compose I do see the package in the ironic-conductor container
(undercloud) [stack@undercloud-0 ~]$ sudo podman exec -it ironic_conductor rpm -qa | grep ovirt
python3-ovirt-engine-sdk4-4.2.9-3.el8ost.x86_64

So the attached patch seems ok, investigating why we are getting "Error: name \'sdk\' is not defined'".

Comment 8 Bob Fournier 2019-06-19 14:09:27 UTC
As it looks like package is there, moving this back to ON_QA, we'll focus on the problem in https://bugzilla.redhat.com/show_bug.cgi?id=1721607

Comment 9 Alexander Chuzhoy 2019-06-19 14:40:30 UTC
Verified based on comment #7
Environment:
openstack-tripleo-common-10.7.1-0.20190614200406.277902e.el8ost.noarch

The RPM is there
(undercloud) [stack@undercloud ~]$ sudo podman exec -it ironic_conductor rpm -qa | grep ovirt
python3-ovirt-engine-sdk4-4.2.9-3.el8ost.x86_64

Comment 13 errata-xmlrpc 2019-09-21 11:20:27 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2019:2811


Note You need to log in before you can comment on or make changes to this bug.