Bug 1721607 - Unable to import nodes using staging-ovirt driver. Error: "Failed to get power state for node 1b246f12-ba40-446d-a215-834b07d1a41f. Error: name 'sdk' is not defined " [NEEDINFO]
Summary: Unable to import nodes using staging-ovirt driver. Error: "Failed to get powe...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-ovirt-engine-sdk4
Version: 15.0 (Stein)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: beta
: 15.0 (Stein)
Assignee: RHOS Maint
QA Contact: Alexander Chuzhoy
URL:
Whiteboard:
Depends On:
Blocks: 1739616
TreeView+ depends on / blocked
 
Reported: 2019-06-18 17:00 UTC by Alexander Chuzhoy
Modified: 2019-09-26 10:52 UTC (History)
9 users (show)

Fixed In Version: python-ovirt-engine-sdk4-4.2.9-4.el8ost
Doc Type: No Doc Update
Doc Text:
Clone Of:
: 1739616 (view as bug list)
Environment:
Last Closed: 2019-09-21 11:23:21 UTC
Target Upstream Version:
gregraka: needinfo? (rhos-maint)
gregraka: needinfo? (rhos-maint)


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2019:2811 0 None None None 2019-09-21 11:23:36 UTC

Description Alexander Chuzhoy 2019-06-18 17:00:51 UTC
Unable to import nodes using staging-ovirt driver. Error: "Failed to get power state for node 1b246f12-ba40-446d-a215-834b07d1a41f. Error: name 'sdk' is not defined "


Environment:
openstack-ironic-staging-drivers-0.11.1-0.20190420132245.b7c6755.el8ost.noarch
openstack-tripleo-common-10.7.1-0.20190614200406.277902e.el8ost


Steps to reproduce:

Deploy undercloud with:
enabled_hardware_types = ipmi,staging-ovirt


Try to import nodes.

Node definition example from istackenv.json:
      "name": "compute-0",
      "mac": ["00:1a:4a:23:13:4f"],
      "pm_addr": "FQDN",
      "pm_type": "staging-ovirt",
      "pm_user": "<USERNAME>",
      "pm_vm_name": "compute",
      "pm_password": "<PASSWORD>"
      }



Result:
+ openstack overcloud node import /home/stack/instackenv.json
Waiting for messages on queue 'tripleo' with no timeout.
Exception registering nodes: {'result': 'Failure caused by error in tasks: send_message\n\n  send_message [task_ex_id=59763261-373f-4809-9885-33db422219aa] -> Workflow failed due to message status. Status:FAILED Message:({\'result\': \'Node 1b246f12-ba40-446d-a215-834b07d1a41f did not reach state "manageable", the state is "enroll", error: Failed to get power state for node 1b246f12-ba40-446d-a215-834b07d1a41f. Error: name \\\'sdk\\\' is not defined\'}, {\'result\': \'Node 7c0d081c-3c54-4657-adf7-42b04d240b20 did not reach state "manageable", the state is "enroll", error: Failed to get power state for node 7c0d081c-3c54-4657-adf7-42b04d240b20. Error: name \\\'sdk\\\' is not defined\'}, {\'result\': \'Node b866b636-52f4-4cd9-947e-2a572d02c474 did not reach state "manageable", the state is "enroll", error: Failed to get power state for node b866b636-52f4-4cd9-947e-2a572d02c474. Error: name \\\'sdk\\\' is not defined\'}, {\'result\': \'Node b8ea8681-9418-405c-aa0c-da5022acc160 did not reach state "manageable", the state is "enroll", error: Failed to get power state for node b8ea8681-9418-405c-aa0c-da5022acc160. Error: name \\\'sdk\\\' is not defined\'})\n    [wf_ex_id=8ced74e6-427f-4c3d-a7b8-271368a6482a, idx=0]: Workflow failed due to message status. Status:FAILED Message:({\'result\': \'Node 1b246f12-ba40-446d-a215-834b07d1a41f did not reach state "manageable", the state is "enroll", error: Failed to get power state for node 1b246f12-ba40-446d-a215-834b07d1a41f. Error: name \\\'sdk\\\' is not defined\'}, {\'result\': \'Node 7c0d081c-3c54-4657-adf7-42b04d240b20 did not reach state "manageable", the state is "enroll", error: Failed to get power state for node 7c0d081c-3c54-4657-adf7-42b04d240b20. Error: name \\\'sdk\\\' is not defined\'}, {\'result\': \'Node b866b636-52f4-4cd9-947e-2a572d02c474 did not reach state "manageable", the state is "enroll", error: Failed to get power state for node b866b636-52f4-4cd9-947e-2a572d02c474. Error: name \\\'sdk\\\' is not defined\'}, {\'result\': \'Node b8ea8681-9418-405c-aa0c-da5022acc160 did not reach state "manageable", the state is "enroll", error: Failed to get power state for node b8ea8681-9418-405c-aa0c-da5022acc160. Error: name \\\'sdk\\\' is not defined\'})\n', 'status': 'FAILED', 'message': [{'result': 'Node 1b246f12-ba40-446d-a215-834b07d1a41f did not reach state "manageable", the state is "enroll", error: Failed to get power state for node 1b246f12-ba40-446d-a215-834b07d1a41f. Error: name \'sdk\' is not defined'}, {'result': 'Node 7c0d081c-3c54-4657-adf7-42b04d240b20 did not reach state "manageable", the state is "enroll", error: Failed to get power state for node 7c0d081c-3c54-4657-adf7-42b04d240b20. Error: name \'sdk\' is not defined'}, {'result': 'Node b866b636-52f4-4cd9-947e-2a572d02c474 did not reach state "manageable", the state is "enroll", error: Failed to get power state for node b866b636-52f4-4cd9-947e-2a572d02c474. Error: name \'sdk\' is not defined'}, {'result': 'Node b8ea8681-9418-405c-aa0c-da5022acc160 did not reach state "manageable", the state is "enroll", error: Failed to get power state for node b8ea8681-9418-405c-aa0c-da5022acc160. Error: name \'sdk\' is not defined'}]}

[{'result': 'Node 1b246f12-ba40-446d-a215-834b07d1a41f did not reach state "manageable", the state is "enroll", error: Failed to get power state for node 1b246f12-ba40-446d-a215-834b07d1a41f. Error: name \'sdk\' is not defined'}, {'result': 'Node 7c0d081c-3c54-4657-adf7-42b04d240b20 did not reach state "manageable", the state is "enroll", error: Failed to get power state for node 7c0d081c-3c54-4657-adf7-42b04d240b20. Error: name \'sdk\' is not defined'}, {'result': 'Node b866b636-52f4-4cd9-947e-2a572d02c474 did not reach state "manageable", the state is "enroll", error: Failed to get power state for node b866b636-52f4-4cd9-947e-2a572d02c474. Error: name \'sdk\' is not defined'}, {'result': 'Node b8ea8681-9418-405c-aa0c-da5022acc160 did not reach state "manageable", the state is "enroll", error: Failed to get power state for node b8ea8681-9418-405c-aa0c-da5022acc160. Error: name \'sdk\' is not defined'}]
{'result': 'Failure caused by error in tasks: send_message\n\n  send_message [task_ex_id=59763261-373f-4809-9885-33db422219aa] -> Workflow failed due to message status. Status:FAILED Message:({\'result\': \'Node 1b246f12-ba40-446d-a215-834b07d1a41f did not reach state "manageable", the state is "enroll", error: Failed to get power state for node 1b246f12-ba40-446d-a215-834b07d1a41f. Error: name \\\'sdk\\\' is not defined\'}, {\'result\': \'Node 7c0d081c-3c54-4657-adf7-42b04d240b20 did not reach state "manageable", the state is "enroll", error: Failed to get power state for node 7c0d081c-3c54-4657-adf7-42b04d240b20. Error: name \\\'sdk\\\' is not defined\'}, {\'result\': \'Node b866b636-52f4-4cd9-947e-2a572d02c474 did not reach state "manageable", the state is "enroll", error: Failed to get power state for node b866b636-52f4-4cd9-947e-2a572d02c474. Error: name \\\'sdk\\\' is not defined\'}, {\'result\': \'Node b8ea8681-9418-405c-aa0c-da5022acc160 did not reach state "manageable", the state is "enroll", error: Failed to get power state for node b8ea8681-9418-405c-aa0c-da5022acc160. Error: name \\\'sdk\\\' is not defined\'})\n    [wf_ex_id=8ced74e6-427f-4c3d-a7b8-271368a6482a, idx=0]: Workflow failed due to message status. Status:FAILED Message:({\'result\': \'Node 1b246f12-ba40-446d-a215-834b07d1a41f did not reach state "manageable", the state is "enroll", error: Failed to get power state for node 1b246f12-ba40-446d-a215-834b07d1a41f. Error: name \\\'sdk\\\' is not defined\'}, {\'result\': \'Node 7c0d081c-3c54-4657-adf7-42b04d240b20 did not reach state "manageable", the state is "enroll", error: Failed to get power state for node 7c0d081c-3c54-4657-adf7-42b04d240b20. Error: name \\\'sdk\\\' is not defined\'}, {\'result\': \'Node b866b636-52f4-4cd9-947e-2a572d02c474 did not reach state "manageable", the state is "enroll", error: Failed to get power state for node b866b636-52f4-4cd9-947e-2a572d02c474. Error: name \\\'sdk\\\' is not defined\'}, {\'result\': \'Node b8ea8681-9418-405c-aa0c-da5022acc160 did not reach state "manageable", the state is "enroll", error: Failed to get power state for node b8ea8681-9418-405c-aa0c-da5022acc160. Error: name \\\'sdk\\\' is not defined\'})\n', 'status': 'FAILED', 'message': [{'result': 'Node 1b246f12-ba40-446d-a215-834b07d1a41f did not reach state "manageable", the state is "enroll", error: Failed to get power state for node 1b246f12-ba40-446d-a215-834b07d1a41f. Error: name \'sdk\' is not defined'}, {'result': 'Node 7c0d081c-3c54-4657-adf7-42b04d240b20 did not reach state "manageable", the state is "enroll", error: Failed to get power state for node 7c0d081c-3c54-4657-adf7-42b04d240b20. Error: name \'sdk\' is not defined'}, {'result': 'Node b866b636-52f4-4cd9-947e-2a572d02c474 did not reach state "manageable", the state is "enroll", error: Failed to get power state for node b866b636-52f4-4cd9-947e-2a572d02c474. Error: name \'sdk\' is not defined'}, {'result': 'Node b8ea8681-9418-405c-aa0c-da5022acc160 did not reach state "manageable", the state is "enroll", error: Failed to get power state for node b8ea8681-9418-405c-aa0c-da5022acc160. Error: name \'sdk\' is not defined'}]}

Comment 1 Alexander Chuzhoy 2019-06-18 20:43:34 UTC

*** This bug has been marked as a duplicate of bug 1683746 ***

Comment 2 Bob Fournier 2019-06-19 14:08:04 UTC
We've verified that the python3-ovirt-engine-sdk4 is there in composes after 6/14 (at least)

(undercloud) [stack@undercloud-0 ~]$ sudo podman exec -it ironic_conductor rpm -qa | grep ovirt
python3-ovirt-engine-sdk4-4.2.9-3.el8ost.x86_64

I'm going to remove this a dup to the patch for the missing package so we can focus on the error message.

Comment 3 Bob Fournier 2019-06-19 14:29:25 UTC
Related bug from osp-13 https://bugzilla.redhat.com/show_bug.cgi?id=1626341, however I don't think we need to restart ironic-conductor container in this case.

Comment 4 Lon Hohberger 2019-06-19 18:15:48 UTC
python-ovirt-engine-sdk4-4.2.9-4.el8ost has been built which fixes the issue

Comment 7 Bob Fournier 2019-06-19 18:42:30 UTC
Temporarily removing blocker flag, will reinstate.

Comment 13 Alexander Chuzhoy 2019-07-03 17:04:05 UTC
Verified:

Environment:
python3-ovirt-engine-sdk4-4.2.9-4.el8ost.x86_64

The reported issue doesn't reproduce.

Comment 17 errata-xmlrpc 2019-09-21 11:23:21 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2019:2811


Note You need to log in before you can comment on or make changes to this bug.