Bug 168393 - SAN boot fails if install target is multipathed
SAN boot fails if install target is multipathed
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: anaconda (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Release Test Team
:
: 168395 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-15 13:29 EDT by Arthur Benoit
Modified: 2010-05-20 11:01 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-20 11:01:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Arthur Benoit 2005-09-15 13:29:00 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; .NET CLR 1.1.4322)

Description of problem:
I install my OS on an EMC Clariion LUN. After the install completes the host gets rebooted. Once the host is back up I find that /boot is not mounted. In the /var/log/messages file is see errors LABEL=/boot duplicate not mounted. If all but one active paths are removed I do not see the problem. The issue is that during the system boot up the LABEL does not appear to be in any way compared to the duplicate LABEL's. In a multipath enviroment every device will need to be available through several alternate paths. A simple check for a unique disk identifier would most likely fix the problem.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Install OS on multipath target with 2 or more active methods of connection
2.
3.
  

Expected Results:  /boot was not mounted.

Additional info:
Comment 1 Suzanne Hillman 2005-09-16 12:55:55 EDT
*** Bug 168395 has been marked as a duplicate of this bug. ***
Comment 2 Arthur Benoit 2005-09-16 14:36:47 EDT
This creates a problem for disks slated to be used in the native multipath 
failover product.
Comment 3 Arthur Benoit 2005-09-20 10:21:23 EDT
FYI My testing on another 2.6 based Enterprise Server Linux showed that it can 
correctly identify labeled multipath LUNS. This testing also showed that when 2 
LUNS were given the same label it was able to correctly fail to mount the 
device with the duplicate label error. My hope in bring this to light (adding 
this comment) is that a fix for the problem might be available in an up-stream 
version. I thought that if RedHat were aware of a potential fix for the problem 
it might help resolve this. 
Comment 4 Heather Conway 2005-09-23 11:42:38 EDT
Arthur - currently, Red Hat is not supporting booting from the SAN with 
multiple paths.
Are you using PowerPath or the device-mapper-multipath?  Are you using LVM2 in 
conjunction with the multipath functionality?
Thanks.
Heather
Comment 5 Arthur Benoit 2005-10-03 08:21:22 EDT
I was attempting to use the native failover product.
Comment 6 Arthur Benoit 2005-10-03 10:46:04 EDT
I got as far a installing the OS on a network drive and rebooting. the /boot 
partition did not mount because it saw multiple copies of the disk label. My 
plan was to test the device-mapper-multipath bundled with Update 2. Also LVM is 
configured during the initial install for the / partition. When is boot from 
SAN targeted for support in RHEL4 using MPIO?
Comment 7 Heather Conway 2006-01-04 09:49:14 EST
At this point in time, I am not sure if or when SAN boot is going to be 
supported when using the device-mapper MPIO.
Alasdair - do you have any insight into this?
Thanks.
Comment 9 Chris Lumens 2010-05-20 11:01:20 EDT
We have no plans to add multipath fixes to anaconda for RHEL4.  That support first appeared in RHEL5.1 (or .2) and was very complicated to get right.  It's too much work to backport into RHEL4 without the potential for major destabilization.

Note You need to log in before you can comment on or make changes to this bug.