Bug 168446 - vte python binding failure
Summary: vte python binding failure
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: vte (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Ray Strode [halfline]
QA Contact:
URL:
Whiteboard:
Keywords:
: 174066 (view as bug list)
Depends On:
Blocks: FC5Blocker
TreeView+ depends on / blocked
 
Reported: 2005-09-16 01:40 UTC by Sam Varshavchik
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-11 16:58:28 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Sam Varshavchik 2005-09-16 01:40:00 UTC
Description of problem:

The python bindings breaks on FC3 + all updates applied.

Version-Release number of selected component (if applicable):

vte-0.11.14-3.fc3

How reproducible:

always

Steps to Reproduce:


$ python
Python 2.3.4 (#1, Feb  2 2005, 12:11:53)
[GCC 3.4.2 20041017 (Red Hat 3.4.2-6.fc3)] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> import vte


  
Actual results:

Traceback (most recent call last):
  File "<stdin>", line 1, in ?
ImportError: /usr/lib/python2.3/site-packages/gtk-2.0/vtemodule.so: undefined
symbol: pyg_set_object_has_new_constructor

Expected results:

The python binding to load.

Additional info:

Google suggests that vte is using an obsolete pygtk2 API, that has been removed
some time ago.

Comment 1 Warren Togami 2005-09-16 07:47:09 UTC
Can you please report this to upstream bugzilla.gnome.org too, and post the link
here?


Comment 2 Sam Varshavchik 2005-09-16 10:59:47 UTC
http://bugzilla.gnome.org/show_bug.cgi?id=316457

Comment 3 Warren Togami 2005-09-16 13:33:09 UTC
Oracle, I highly suggest that you investigate into this issue if you rely on
this feature for your product, as the newer upstream GNOME.org versions of vte
seem to be broken with vte python bindings.  This means it is currently broken
for RHEL5, and any users using FC3, FC4, or FC5 with Oracle.

Comment 4 Scott Tsai 2005-11-24 09:15:36 UTC
*** Bug 174066 has been marked as a duplicate of this bug. ***

Comment 5 Scott Tsai 2005-11-24 09:23:08 UTC
see:
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=338090

I suggest emulating the debian solution if possible,
ie. rm python/vte.c and rebuild.

Comment 6 Ray Strode [halfline] 2006-01-11 16:58:28 UTC
Hi, this seems to be fixed with vte-0.11.16 and pygtk 2.8


Note You need to log in before you can comment on or make changes to this bug.