Bug 174066 - python module import error
Summary: python module import error
Status: CLOSED DUPLICATE of bug 168446
Alias: None
Product: Fedora
Classification: Fedora
Component: vte (Show other bugs)
(Show other bugs)
Version: 4
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Warren Togami
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-11-24 09:11 UTC by Scott Tsai
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-24 09:15:31 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Scott Tsai 2005-11-24 09:11:25 UTC
Description of problem:
When trying to import the vte python module an 'undefined symbol' error occurs.

Version-Release number of selected component (if applicable):
vte-0.11.14-3.fc4

How reproducible:
always


Steps to Reproduce:
1. python -c 'import vte'
  
Actual results:
Traceback (most recent call last):
  File "<string>", line 1, in ?
ImportError: /usr/lib/python2.4/site-packages/gtk-2.0/vtemodule.so: undefined
symbol: pyg_set_object_has_new_constructor


Expected results:
/usr/bin/python should return 0

Additional info:
bug also present on FC3:
https://www.redhat.com/archives/fedora-devel-list/2005-September/msg00268.html

My guess is that you built vte with the wrong version of pygtk.

Comment 1 Scott Tsai 2005-11-24 09:15:31 UTC

*** This bug has been marked as a duplicate of 168446 ***


Note You need to log in before you can comment on or make changes to this bug.