Bug 1684517 - Regression in "package-cleanup --orphans"
Summary: Regression in "package-cleanup --orphans"
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf
Version: 30
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jaroslav Mracek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 1568740
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-01 12:25 UTC by Miroslav Suchý
Modified: 2020-02-18 16:16 UTC (History)
13 users (show)

Fixed In Version: dnf-4.2.11-2.fc30
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-10-10 16:55:50 UTC
Type: Bug


Attachments (Terms of Use)

Description Miroslav Suchý 2019-03-01 12:25:44 UTC
Description of problem:
Command 
  package-cleanup --orphans
which maps (see bug 1216179) to:
  dnf list extras
should produce (extracted from man page):
  Lists extras, that is packages installed on the system that are not available in any known repository.

however, on my system - it prints all installed packages. I even tried 'dnf makecache' but it does not help.

Running this command is encouraged to run after system upgrade (from N to N+1) to remove orphaned/retired packages which has not been added (for any reason) to fedora-obsolete-packages. I do that automatically in fedora-upgrade(8).


Version-Release number of selected component (if applicable):
dnf-4.0.9-2.fc29.noarch
dnf-plugins-core-4.0.2-1.fc29.noarch

Comment 1 Jaroslav Mracek 2019-07-25 07:10:30 UTC
It looks like that the issue cannot be reproduce with dnf-4.2.5, therefore it should be fixed.

Comment 2 Miroslav Suchý 2019-07-25 07:43:22 UTC
Negative sir. I can reproduce it with dnf-4.2.5-2.fc30.noarch

Comment 3 Lukáš Hrázký 2019-08-21 10:44:21 UTC
It is not at all obvious how this depends on 1568740.

Comment 4 Jaroslav Mracek 2019-09-03 07:55:11 UTC
I created PR that change behavior of detection of extras: https://github.com/rpm-software-management/libdnf/pull/776.

Test for the new behavior: Tests: rpm-software-management/ci-dnf-stack#617

Comment 5 Fedora Update System 2019-10-02 08:31:45 UTC
FEDORA-2019-049b4836a6 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-049b4836a6

Comment 6 Fedora Update System 2019-10-03 01:52:24 UTC
dnf-4.2.11-2.fc30, dnf-plugins-core-4.0.10-1.fc30, libdnf-0.35.5-2.fc30, librepo-1.10.6-1.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-049b4836a6

Comment 7 Fedora Update System 2019-10-10 16:55:50 UTC
dnf-4.2.11-2.fc30, dnf-plugins-core-4.0.10-1.fc30, libdnf-0.35.5-2.fc30, librepo-1.10.6-1.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.

Comment 8 Sergio Basto 2020-02-18 16:16:32 UTC
(In reply to Miroslav Suchý from comment #0)
> Description of problem:
> Command 
>   package-cleanup --orphans
> which maps (see bug 1216179) to:
>   dnf list extras
> should produce (extracted from man page):
>   Lists extras, that is packages installed on the system that are not
> available in any known repository.

the packages with different versions should be listed , as always did . 

If we a have package v1 and repo have package v2 , list extra should print it . they are different packages !


Note You need to log in before you can comment on or make changes to this bug.