Bug 168561 - can't start X server after the upgrade
can't start X server after the upgrade
Status: CLOSED DUPLICATE of bug 168752
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
4
i686 Linux
medium Severity high
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-17 02:26 EDT by petrosyan
Modified: 2007-11-30 17:11 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-19 22:15:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg log file (61.33 KB, text/plain)
2005-09-17 02:27 EDT, petrosyan
no flags Details
Diff from Xorg.0.log (working) to Xorg.0.log (not working) (13.42 KB, text/plain)
2005-09-17 07:09 EDT, Matthias Hensler
no flags Details

  None (edit)
Description petrosyan 2005-09-17 02:26:52 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6

Description of problem:
After installing the latest x11-xorg updates for Fedora Core 4, I can't boot into it anymore. The screen gets garbled, and I can't do anything with the computer.

It is a Thinkpad X40. Attaching the log file...

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. install the latest FC4 updates
2. reboot

Actual Results:  the computer doesn't boot anymore

Expected Results:  the computer should boot

Additional info:
Comment 1 petrosyan 2005-09-17 02:27:31 EDT
Created attachment 118926 [details]
Xorg log file
Comment 2 Andrey 2005-09-17 03:02:18 EDT
I can't boot into it anymore.
I install latest FC4 updates xorg-x11-6.8.2-37.FC4.48.1.

video:
VGA compatible controller: Intel Corporation 82845G/GL[Brookdale-G]/GE Chipset
Integrated Graphics Device (rev 1).
      IRQ 11.
      Prefetchable 32 bit memory at 0xf0000000 [0xf7ffffff].
      Non-prefetchable 32 bit memory at 0xffa80000 [0xffafffff].

i get message dmesg:

[drm] Initialized i915 1.1.0 20040405 on minor 0: Intel Corporation
82845G/GL[Brookdale-G]/GE Chipset Integrated Graphics Device
mtrr: base(0xf0020000) is not aligned on a size(0x400000) boundary
agpgart: pg_start == 0x00000000,intel_i830_private.gtt_entries == 0x000000df
agpgart: Trying to insert into local/stolen memory
mtrr: base(0xf0020000) is not aligned on a size(0x400000) boundary
agpgart: pg_start == 0x00000000,intel_i830_private.gtt_entries == 0x000000df
agpgart: Trying to insert into local/stolen memory
Comment 3 Andrey 2005-09-17 03:04:26 EDT
tail /var/log/Xorg.0.log:

(II) Loading sub module "int10"
(II) LoadModule: "int10"
(II) Reloading /usr/X11R6/lib/modules/linux/libint10.a
(II) I810(0): initializing int10
(WW) I810(0): Bad V_BIOS checksum
(II) I810(0): Primary V_BIOS segment is: 0xc000
(II) I810(0): VESA BIOS detected
(II) I810(0): VESA VBE Version 3.0
(II) I810(0): VESA VBE Total Mem: 12288 kB
(II) I810(0): VESA VBE OEM: Intel(r)845G/845GL/845GE/845GV Graphics Chip
Accelerated VGA BIOS
(II) I810(0): VESA VBE OEM Software Rev: 1.0
(II) I810(0): VESA VBE OEM Vendor: Intel Corporation
(II) I810(0): VESA VBE OEM Product: Intel(r)845G/845GL/845GE/845GV Graphics
Controller
(II) I810(0): VESA VBE OEM Product Rev: Hardware Version 0.0
(II) I810(0): Allocated 128 kB for the ring buffer at 0x0
(II) I810(0): Allocating at least 384 scanlines for pixmap cache
(II) I810(0): Initial framebuffer allocation size: 5632 kByte
(II) I810(0): Allocated 4 kB for HW cursor at 0x7fff000
(II) I810(0): Allocated 16 kB for HW (ARGB) cursor at 0x7ffb000
(II) I810(0): Allocated 4 kB for Overlay registers at 0x7ffa000 (0x1da9f000).
(II) I810(0): Allocated 64 kB for the scratch buffer at 0x7fea000
drmOpenDevice: node name is /dev/dri/card0
drmOpenDevice: open result is 8, (OK)
drmOpenDevice: node name is /dev/dri/card0
drmOpenDevice: open result is 8, (OK)
drmOpenByBusid: Searching for BusID pci:0000:00:02.0
drmOpenDevice: node name is /dev/dri/card0
drmOpenDevice: open result is 8, (OK)
drmOpenByBusid: drmOpenMinor returns 8
drmOpenByBusid: drmGetBusid reports pci:0000:00:02.0
(II) I810(0): [drm] DRM interface version 1.2
(II) I810(0): [drm] created "i915" driver at busid "pci:0000:00:02.0"
(II) I810(0): [drm] added 8192 byte SAREA at 0xe097e000
(II) I810(0): [drm] mapped SAREA 0xe097e000 to 0xb7e8f000
(II) I810(0): [drm] framebuffer handle = 0xf0020000
(II) I810(0): [drm] added 1 reserved context for kernel
(II) I810(0): Allocated 4096 kB for the back buffer at 0x7800000.
(II) I810(0): Allocated 4096 kB for the depth buffer at 0x7400000.
(II) I810(0): Allocated 32 kB for the logical context at 0x73f8000.
(II) I810(0): Allocated 51456 kB for textures at 0x41b8000
(II) I810(0): Updated framebuffer allocation size from 5632 to 5640 kByte
(II) I810(0): Updated pixmap cache from 384 scanlines to 386 scanlines
(II) I810(0): 0x8536a44: Memory at offset 0x00020000, size 5640 kBytes
(II) I810(0): 0x849f4d8: Memory at offset 0x07fff000, size 4 kBytes
(II) I810(0): 0x849f500: Memory at offset 0x07ffb000, size 16 kBytes
(II) I810(0): 0x85674d4: Memory at offset 0x00000000, size 128 kBytes
(II) I810(0): 0x8536a84: Memory at offset 0x07fea000, size 64 kBytes
(II) I810(0): 0x857eb90: Memory at offset 0x07ffa000, size 4 kBytes
(II) I810(0): 0x8536ad4: Memory at offset 0x07800000, size 4096 kBytes
(II) I810(0): 0x8536af4: M0, size 4096 kBytes
(II) I810(0): 0x8536b34: Memory at offset 0x073f8000, size 32 kBytes
(II) I810(0): 0x8536b14: Memory at offset 0x041b8000, size 51456 kBytes
(II) I810(0): Activating tiled memory for the back buffer.
(II) I810(0): Activating tiled memory for the depth buffer.
(II) I810(0): [drm] Registers = 0xffa80000
(II) I810(0): [drm] Back Buffer = 0xf7800000
(II) I810(0): [drm] Depth Buffer = 0xf7400000
(II) I810(0): [drm] ring buffer = 0xf0000000
(II) I810(0): [drm] textures = 0xf41b8000
(II) I810(0): [drm] dma control initialized, using IRQ 11
(II) I810(0): [drm] Initialized kernel agp heap manager, 52690944
(II) I810(0): [dri] visual configs initialized
(==) I810(0): Write-combining range (0xf0000000,0x8000000)
(II) I810(0): vgaHWGetIOBase: hwp->IOBase is 0x03d0, hwp->PIOOffset is 0x0000
(WW) I810(0): Extended BIOS function 0x5f05 not supported.
(II) I810(0): xf86BindGARTMemory: bind key 8 at 0x00000000 (pgoffset 0)
(WW) I810(0): xf86BindGARTMemory: binding of gart memory with key 8
        at offset 0x0 failed (Invalid argument)

Fatal server error:
AddScreen/ScreenInit failed for driver 0


Please consult the The X.Org Foundation support 
         at http://wiki.X.Org
 for help. 
Please also check the log file at "/var/log/Xorg.0.log" for additional information.
Comment 4 Matthias Hensler 2005-09-17 07:06:27 EDT
I can confirm this on an Asus M5N series notebook (Intel 855GME chipset).

I attach the diff of the Xorg.0.log from working to non working.
Comment 5 Matthias Hensler 2005-09-17 07:09:56 EDT
Created attachment 118931 [details]
Diff from Xorg.0.log (working) to Xorg.0.log (not working)

Attached is the diff of Xorg.0.log from working to non-working. The
kernel-versions is different between the two logfiles, however, the problem is
reproducable with three different kernels (two customs, based on 1398_FC4 and
1555_FC5, and offical 1398_FC4).
Comment 6 Joel Gomberg 2005-09-17 11:30:01 EDT
I have encountered a similar problem on my x86_64 system, with an Nvidia 5500
series card and the Nvidia proprietary driver.  The X server reports that it
cannot load glx and returns a signal 11 error.  If I change the driver from
"nvidia" to "nv" X will start.
Comment 7 Joel Gomberg 2005-09-17 13:48:26 EDT
Update:  Re-running the Nvidia installer fixed the problem.
Comment 8 Lonni J Friedman 2005-09-17 18:38:02 EDT
Same problem here on a Sharp laptop that has the i945 video chipset.
Comment 9 jehan procaccia 2005-09-19 08:01:29 EDT
same problem while upgrading from xorg-x11-6.8.2-37.FC4.45 to
xorg-x11-6.8.2-37.FC4.48.1 , using i810 driver for ->
 product: 82865G Integrated Graphics Controller
it crashes all our computer labs, 100 machines :-( .
solution downgrade xorg, but not very convenient .
Comment 10 Jim Cornette 2005-09-19 08:28:19 EDT
As a reference to Intel video cards which are not effected by this bug, I tested
out the latest rpms for FC3 and again for FC4 on a computer with an Intel 815
video card. This card did not fail and worked for both FC3 and FC4 version of
xorg-x11.
These cards are the lower cards and do not have features that the Intel 830 and
above are capable of. The breakage is more likely related to these extra
capabilities that the better video cards can achieve.

Adding to CC: I have an Intel 865G on another computer5 and still have
xorg-x11-6.8.2-37 installed and it is working alright. Holding off until this
problem is resolved for the 865G.
Comment 11 David Perkinson 2005-09-19 13:46:00 EDT
I have a thinkpad x40 (Intel 82852/855GM video) with the identical problem:

"After installing the latest x11-xorg updates for Fedora Core 4, I can't boot
into it anymore. The screen gets garbled, and I can't do anything with the
computer."

I am trying to figure out how to downgrade.  Any advice (with specific commands)
would be appreciated.
Comment 12 Jim Cornette 2005-09-19 15:03:08 EDT
You have two options you can try. The first opton is to keep the new xorg-x11
rpms installed and to instead change your driver from i810 to vesa in the
/etc/X11/xorg.conf file.
The other option is to mount the media which contains the RPMS from the original
installation discs. Change to the directory that contains the rpms and then as
root try to run 
rpm -Uvh xorg*.<arch>.rpm --oldpackage
the <arch> should be changed to i386, ppc or whatever arch you are running.

To find out all rpms which are needed to downgrade your xorg-x11 installation.
rpm -qa |grep xorg 
should show all of the xorg related packages, including the font packages. You
can put the older packages from the CDs into a seperate directory on your hard
drive if the packages span across several CDs to overcome any dep errors.
Comment 13 John Mahowald 2005-09-19 21:51:31 EDT

*** This bug has been marked as a duplicate of 168562 ***
Comment 14 Mike A. Harris 2005-09-19 22:15:31 EDT

*** This bug has been marked as a duplicate of 168752 ***

Note You need to log in before you can comment on or make changes to this bug.