Bug 168562 - X wont start after xorg updates via yum on 17/09/05
X wont start after xorg updates via yum on 17/09/05
Status: CLOSED DUPLICATE of bug 168752
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
4
i686 Linux
medium Severity high
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-17 04:54 EDT by nicholas manojlovic
Modified: 2007-11-30 17:11 EST (History)
16 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-19 22:04:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
X server log (52.20 KB, text/plain)
2005-09-17 12:38 EDT, Robert G. Fries
no flags Details

  None (edit)
Description nicholas manojlovic 2005-09-17 04:54:52 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6

Description of problem:
The xorg-X11 updates released via yum updates on or around the 17th Sept, 2005 appear faulty.

It appears to be common:
http://forums.fedoraforum.org/showthread.php?p=368158#post368158
http://forums.fedoraforum.org/showthread.php?p=368155#post368155

This report is for a standard Intel 865 chipset on PIV, and fails against SMP kernels. 



Version-Release number of selected component (if applicable):
unknown, apologies

How reproducible:
Always

Steps to Reproduce:
1. updated via fedora extras as enabled by fedora default install
2. installed cleanly without error messages
3. following restart, X is garbled. screen light turns on and off as if in power saving mode after a minute or so, although garbled screen remains. ctrl-alt-delete restarts. ctl-alt-backspace does not kill X. ctrl-alt-F1 does not enter runlevel 3. garbled screen remains. 
  

Additional info:
Comment 1 Sebastiaan Janssens 2005-09-17 07:43:37 EDT
The same here, on a Dell Latitude D505 with an Intel i810 video card.
Comment 2 Mark Knoop 2005-09-17 08:19:01 EDT
It's not from Fedora Extras - it's in the updates repo. 

xorg-x11 - 6.8.2-37.FC4.48.1.i386 (and related).
Comment 3 Kenneth Russell 2005-09-17 10:37:45 EDT
Same here as well, on a Dell Dimension 2400 with Intel 845 integrated video.
Comment 4 Jacco Ligthart 2005-09-17 10:51:03 EDT
Same here. My machine keeps rebooting with the new xorg-x11 packages. My video
hw is 1 MGA G550 and 1 ATI Mach64.
Comment 5 Richard 2005-09-17 10:55:01 EDT
My exact poroblem too running Intel 865G Northbridge (Shuttle xPC SB61G2 v4). 
No way out but to reboot `linux rescue` from CD.
Anyone know of a patch or a config mod?
Comment 6 Robert G. Fries 2005-09-17 11:44:49 EDT
Same problem w/ intel 845G chipset. Effects FC3 as well as FC4.
Comment 7 Enrique 2005-09-17 12:08:52 EDT
Same problem in a Compaq SS5300NX with i810.
Comment 8 Robert G. Fries 2005-09-17 12:38:11 EDT
Created attachment 118935 [details]
X server log

Log created via manual startx in run level 3. This system is FC3, intel 845G
chipset.
Comment 9 Wolfgang Rupprecht 2005-09-17 16:13:35 EDT
same problem here on x86_64 w. radeon x300se

system hangs as soon as xorg is started.  Things worked just fine before this
yum update.
Comment 10 Lonni J Friedman 2005-09-17 18:35:48 EDT
Same problem here with i830 chipset.  In dmesg I see the following carnage as X
is starting:

[drm] Initialized i915 1.1.0 20040405 on minor 1: 
mtrr: base(0xe8020000) is not aligned on a size(0x300000) boundary
agpgart: pg_start == 0x00000000,intel_i830_private.gtt_entries == 0x000007df
agpgart: Trying to insert into local/stolen memory
mtrr: base(0xe8020000) is not aligned on a size(0x300000) boundary


Note, this is on a laptop with the non-SMP kernel.
Comment 11 Stanton Finley 2005-09-18 01:09:41 EDT
Same here with a Intel Corporation 82915G/GV/910GL Express Chipset Family
Graphics Controller (rev 04) on a Pentium 4.
Comment 12 Robert Marcano 2005-09-18 07:29:52 EDT
Same here with a 845 chipset. switching temporally to the xorg vesa driver works
perfectly
Comment 13 D. Hugh Redelmeier 2005-09-18 23:14:24 EDT
See these threads:
https://www.redhat.com/archives/fedora-list/2005-September/msg02070.html
https://www.redhat.com/archives/fedora-list/2005-September/msg02082.html
https://www.redhat.com/archives/fedora-list/2005-September/msg02175.html
https://www.redhat.com/archives/fedora-list/2005-September/msg02183.html
https://www.redhat.com/archives/fedora-list/2005-September/msg02268.html

My own entry includes some suggestive differences between Xorg.0.log files for
working and non-working systems.  The working version was xorg*45*.rpm.  The
non-working version was xorg*48.1*.rpm.
https://www.redhat.com/archives/fedora-list/2005-September/msg02276.html

Aside: Although the Intel 915GM isn't supported, there is an easy update
available from
  http://dri.freedesktop.org/snapshots
It would be great to get that folded in.  A lot of recent laptops use this chip.
Comment 14 Fernando J. Leal 2005-09-19 16:24:32 EDT
Same here with a i810 chipset on FC4.
Comment 15 Paul van Maaren 2005-09-19 17:14:41 EDT
Same here with a Intel(r)845G chipset on FC4.

Downgrade fixes it:
rpm -Uhv --oldpackage xorg-x11-6.8.2-37.FC4.45.i386.rpm
xorg-x11-libs-6.8.2-37.FC4.45.i386.rpm xorg-x11-xfs-6.8.2-37.FC4.45.i386.rpm
xorg-x11-devel-6.8.2-37.FC4.45.i386.rpm
xorg-x11-deprecated-libs-devel-6.8.2-37.FC4.45.i386.rpm
xorg-x11-deprecated-libs-6.8.2-37.FC4.45.i386.rpm
Comment 16 John Mahowald 2005-09-19 21:34:15 EDT
*** Bug 168734 has been marked as a duplicate of this bug. ***
Comment 17 John Mahowald 2005-09-19 21:52:01 EDT
*** Bug 168561 has been marked as a duplicate of this bug. ***
Comment 18 Mike A. Harris 2005-09-19 22:02:11 EDT
(In reply to comment #13)

> Aside: Although the Intel 915GM isn't supported, there is an easy update
> available from
>   http://dri.freedesktop.org/snapshots
> It would be great to get that folded in.  A lot of recent laptops use this chip.

Intel i915GM support was added in the update this bug is filed against
already.  ;o)


Comment 19 Mike A. Harris 2005-09-19 22:04:27 EDT

*** This bug has been marked as a duplicate of 168752 ***
Comment 20 Shi-Sheng Sun 2005-09-22 08:23:56 EDT
i have the same trouble with an ASUS Desktop.
i915GM / P4 with HT on FC4
Comment 21 Shi-Sheng Sun 2005-09-23 00:07:59 EDT
i hava update X by yum today, and the trouble has been fixed  :)

xorg-x11.i386                            6.8.2-37.FC4.49.2      updates-
released
xorg-x11-Mesa-libGL.i386                 6.8.2-37.FC4.49.2      updates-
released
xorg-x11-Mesa-libGLU.i386                6.8.2-37.FC4.49.2      updates-
released
xorg-x11-Xdmx.i386                       6.8.2-37.FC4.49.2      updates-
released
xorg-x11-Xnest.i386                      6.8.2-37.FC4.49.2      updates-
released
xorg-x11-Xvfb.i386                       6.8.2-37.FC4.49.2      updates-
released
xorg-x11-deprecated-libs.i386            6.8.2-37.FC4.49.2      updates-
released
xorg-x11-deprecated-libs-devel.i386      6.8.2-37.FC4.49.2      updates-
released
xorg-x11-devel.i386                      6.8.2-37.FC4.49.2      updates-
released
xorg-x11-doc.i386                        6.8.2-37.FC4.49.2      updates-
released
xorg-x11-font-utils.i386                 6.8.2-37.FC4.49.2      updates-
released
xorg-x11-libs.i386                       6.8.2-37.FC4.49.2      updates-
released
xorg-x11-sdk.i386                        6.8.2-37.FC4.49.2      updates-
released
xorg-x11-tools.i386                      6.8.2-37.FC4.49.2      updates-
released
xorg-x11-twm.i386                        6.8.2-37.FC4.49.2      updates-
released
xorg-x11-xauth.i386                      6.8.2-37.FC4.49.2      updates-
released
xorg-x11-xdm.i386                        6.8.2-37.FC4.49.2      updates-
released
xorg-x11-xfs.i386                        6.8.2-37.FC4.49.2      updates-
released

Note You need to log in before you can comment on or make changes to this bug.