Bug 168594 - yumex crashes afer adding plugin
yumex crashes afer adding plugin
Status: CLOSED DUPLICATE of bug 168595
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
http://wiki.linux.duke.edu/WritingYum...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-17 15:15 EDT by Eli Wapniarski
Modified: 2014-01-21 17:52 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-17 15:57:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eli Wapniarski 2005-09-17 15:15:36 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.4; Linux) KHTML/3.4.2 (like Gecko)

Description of problem:
After adding the downloadonly plugin as described at    
http://wiki.linux.duke.edu/WritingYumPlugins and then running yumex without the -n   
switch yumex crashes (traceback to follow). Invoked with the -n switch then yumex runs  
but as soon as I try to update, the same traceback results.  
  
Traceback (most recent call last):  
  File "/usr/share/yumex/yumex.py", line 864, in ?  
    mainApp = MainApplication()  
  File "/usr/share/yumex/yumex.py", line 81, in __init__  
    self.setup_yum()  
  File "/usr/share/yumex/yumex.py", line 836, in setup_yum  
    if self.yw.setup():  
  File "/usr/share/yumex/yumexClasses/yumbase.py", line 81, in setup  
    self.doPluginSetup()  
  File "__init__.py", line 157, in doPluginSetup  
  File "plugins.py", line 143, in __init__  
  File "plugins.py", line 159, in run  
  File "/etc/yum/pluginconf.d/downloadonly.py", line 7, in config_hook  
    parser.add_option('', '--downloadonly', dest='dlonly',  
AttributeError: 'NoneType' object has no attribute 'add_option'  
  

Version-Release number of selected component (if applicable):
yumex-0.42-5.0.fc4

How reproducible:
Always

Steps to Reproduce:
1.  Enable the downloadonly plugin as described at  
http://wiki.linux.duke.edu/WritingYumPlugins 
2.  run yumex 
     

Actual Results:  yumex crashes 

Expected Results:  yumex should run just fine. 

Additional info:
Comment 1 Rahul Sundaram 2005-09-17 15:57:21 EDT
Thank you for the bug report. This particular bug has already been reported
into our bug tracking system, but please feel free to report any further
bugs you find.



*** This bug has been marked as a duplicate of 168595 ***

Note You need to log in before you can comment on or make changes to this bug.