Bug 1685952 - sync daemonset should tolerate taints (3.10)
Summary: sync daemonset should tolerate taints (3.10)
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 3.10.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 3.10.z
Assignee: Vadim Rutkovsky
QA Contact: Siva Reddy
URL:
Whiteboard:
: 1685960 (view as bug list)
Depends On: 1635462
Blocks: 1690200
TreeView+ depends on / blocked
 
Reported: 2019-03-06 11:47 UTC by Sebastian Mossberg
Modified: 2019-06-11 09:31 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: sync daemonset didn't ignore tainted nodes Consequence: if some nodes were tainted, sync pods won't run there and reconcile the config Fix: sync DS pods now tolerate all taints Result: tainted nodes get configuration updated
Clone Of: 1635462
: 1690200 (view as bug list)
Environment:
Last Closed: 2019-06-11 09:30:48 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0786 None None None 2019-06-11 09:30:59 UTC

Comment 2 Vadim Rutkovsky 2019-03-06 11:59:53 UTC
Created 3.10 PR https://github.com/openshift/openshift-ansible/pull/11309

Comment 3 Scott Dodson 2019-03-06 13:33:35 UTC
*** Bug 1685960 has been marked as a duplicate of this bug. ***

Comment 4 Scott Dodson 2019-03-06 13:35:19 UTC
Bug for logging team to evaluate fluentd https://bugzilla.redhat.com/show_bug.cgi?id=1685970

Comment 5 Vadim Rutkovsky 2019-03-08 11:53:51 UTC
Fix is available in openshift-ansible-3.10.123-1

Comment 7 Siva Reddy 2019-03-19 01:30:53 UTC
The sync daemon sets are tolerating the taints put on the node.

Version:
oc v3.10
openshift v3.10

openshift-ansible-3.10.124-1.git.0.0bed46f.el7.noarch.rpm

Steps to reproduce:
1. taint the node
   # oc adm taint node $node NodeWithImpairedVolumes=true:NoExecute
    #oc describe node $node | grep -i taint
2. delete the sync pod ds and recreate it
   # oc get ds sync -o yaml > sync-ds.yaml
   # oc delete ds sync
   # oc create -f sync-ds.yaml
3. Note the sync pods

    The sync pods get created with out any issue in spite of taint being present on the node.Note that the logging pods are still affected by the taints

Comment 12 errata-xmlrpc 2019-06-11 09:30:48 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0786


Note You need to log in before you can comment on or make changes to this bug.