Bug 16861 - sort is broken
Summary: sort is broken
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: textutils (Show other bugs)
(Show other bugs)
Version: 7.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-08-24 13:06 UTC by mandrews
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-24 16:19:38 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description mandrews 2000-08-24 13:06:58 UTC
Tracking down a problem aluded to in [Bug 16806] I found that sort in
pinstriper (textutils-2.0e-7) is broken. I run sort on the following:

/      (everyone)
/tmp   (everyone)
/array (everyone)

and get:

/array (everyone)
/      (everyone)
/tmp   (everyone)

Comment 1 Per Starbäck 2000-08-24 16:19:36 UTC
That is because of LC_COLLATE or LANG.  If you do
$ LC_COLLATE=C sort ...
it will sort as you expected.




Comment 2 Bernhard Rosenkraenzer 2000-08-25 13:32:02 UTC
True - if you want the old behavior, export LC_COLLATE=C in /etc/rc.d/rc.local
or the likes.


Note You need to log in before you can comment on or make changes to this bug.