Bug 168615 - Unable to use shortcut keys to control volume usefully.
Unable to use shortcut keys to control volume usefully.
Status: CLOSED DUPLICATE of bug 201176
Product: Fedora
Classification: Fedora
Component: control-center (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
David Lawrence
Depends On:
  Show dependency treegraph
Reported: 2005-09-18 01:20 EDT by Rodd Clarkson
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-08-04 12:46:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Rodd Clarkson 2005-09-18 01:20:35 EDT
Description of problem:

I have a Dell 9300 which comes with a sub-woofer.

lspci shows that the sound card is a:

00:1e.2 Multimedia audio controller: Intel Corporation 82801FB/FBM/FR/FW/FRW
(ICH6 Family) AC'97 Audio Controller (rev 03)

When I set up the keyboard shortcuts to control the volume and mute it only
affects the main volume, and not the sub-woofer volume.

The main speakers are listing in Volume Manager as Master, with the sub-woofer
controlled by Master Mono.  Unfortunately, the keyboard short cut preferences
only affect Master (and not Master Mono). As a result, the main speakers are
turned down, but the sub-woofer still makes noise.

There needs to be either an inclusion of master mono in what's affected by the
keyboard shortcuts, or some way to lock master mono and master so that work in
unison.  That later would be the better option.
Comment 1 Martin Stransky 2005-09-19 04:20:22 EDT
How did you set up the keyboard shortcuts to control the volume? In other words,
what commands are used for the volume control?
Comment 2 Rodd Clarkson 2005-09-19 05:11:27 EDT
To set up keyboard shortcuts I do the following:

1. Select Desktop > Preferences > Keyboard Shortcuts
2. In the Keyboard Shortcuts dialog, under 'Sound' there are the following options:
    Volume mute
    Volume down
    Volume up
    [Other options to do with playback.]

Click on one of the volume options (which then waits for the next keystroke) and
press the appropriate key.  In my case I have some multimedia keys on the front
of the laptop that I use for this.

The key values are as follows:

    Volume mute : 0xa0
    Volume down : 0xae
    Volume up   : 0xb0
Comment 3 Martin Stransky 2005-09-19 10:31:29 EDT
okay, reassigning to control-center...
Comment 4 Matthias Clasen 2006-08-04 12:46:36 EDT

*** This bug has been marked as a duplicate of 201176 ***
Comment 5 Rodd Clarkson 2007-06-06 06:59:42 EDT
I'm not convinced that this is a dupe.

If I open up the Volume Control I see two Master Volume Controls.  One is called
Master, the other is called Master Mono.  Master controls the stereo sound
volume you would typically find in a laptop and has two sliding bars that are
locked, Master Mono controls the sub-woofer volume and has a single sliding bar.

If I click on the volume up and volume down bottoms on my laptop, then the
Master volume control changes, but the Master Mono volume remains the same.

If I click the mute button, then the Master control is toggled between mute and
normal, but the Master Mono Volume remains unchanged.

It appears that in my case the buttons are working, but they just aren't acting
on all the Master channels.

It is my opinion that clicking these buttons should change all the master volume
controls, not just one set.

Note You need to log in before you can comment on or make changes to this bug.