Bug 201176 - Key shortcuts set in capplet for next/prev song, start/stop playing don't work
Summary: Key shortcuts set in capplet for next/prev song, start/stop playing don't work
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: control-center   
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Control Center Maintainer
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
: 168615 204576 (view as bug list)
Depends On:
Blocks: FC6Desktop
TreeView+ depends on / blocked
 
Reported: 2006-08-03 13:03 UTC by Bill Nottingham
Modified: 2014-03-17 03:01 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-04 16:54:01 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
testaccel.c (7.98 KB, text/x-csrc)
2006-08-25 17:42 UTC, Matthias Clasen
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Bugzilla 133815 None None None Never
GNOME Bugzilla 154944 None None None Never

Description Bill Nottingham 2006-08-03 13:03:39 UTC
At least, not in rhythmbox.

Version-Release number of selected component (if applicable):

control-center-2.15.4-6
rhythmbox-0.9.5-2

Comment 1 Matthias Clasen 2006-08-04 14:03:13 UTC
confirmed

Comment 2 Matthias Clasen 2006-08-04 14:20:10 UTC
Found a possibly related upstream bug

Comment 3 Matthias Clasen 2006-08-04 16:46:52 UTC
*** Bug 168615 has been marked as a duplicate of this bug. ***

Comment 4 Matthias Clasen 2006-08-04 20:20:09 UTC
So, keyboard shortcuts seem to be pretty hosed generally atm. 
We need to look into that for FC6. What happened to me earlier when
I investigated this was that I temporarily assigned Alt-1, Alt-2, etc
to functions. But when I later reset them again, my number keys were dead !
and they stayed dead even after switching keyboard layouts and trying several
other things. That can easily bring users into unfixable situations.

Comment 5 Bill Nottingham 2006-08-04 20:30:03 UTC
Actually, I noticed something similar ; I had ctrl-shift-p as play/pause... and
then this morning I couldn't type a p anywhere in GNOME until I changed the
shortcut, logged out, whacked gconfd, and logged back in.

Comment 6 Bastien Nocera 2006-08-08 08:15:36 UTC
comment 4 and comment 5 are the reason I asked upstream to remove those keys
from the capplet back in GNOME 2.13.
See:
http://bugzilla.gnome.org/show_bug.cgi?id=133815#c32
and
http://bugzilla.gnome.org/show_bug.cgi?id=133815#c24
and other comments in the bug

Upstream didn't think that the fact that I wrote this code was a good enough
reason to disable that broken code...

Comment 7 Matthias Clasen 2006-08-25 17:39:12 UTC
Ray, I spent some time inside XKB today and wrote a little test program
that shows how to grab keys, and also how to ignore locked modifiers.

Comment 8 Matthias Clasen 2006-08-25 17:42:30 UTC
Created attachment 134941 [details]
testaccel.c

Comment 9 Matthias Clasen 2006-08-25 19:19:32 UTC
Forgot to mention that we probably need to keep the "bind all permutations"
code as a fallback for the non-XKB case, at least when moving this upstream.

Comment 10 Ray Strode [halfline] 2006-08-28 14:35:35 UTC
Thanks Matthias!  I didn't know XKB could be leveraged to make this easier.


Comment 11 Jens Knutson 2006-08-30 06:10:33 UTC
*** Bug 204576 has been marked as a duplicate of this bug. ***

Comment 12 Bastien Nocera 2007-04-04 16:40:51 UTC
Ray, isn't this fixed with the 2.18 version of the control-center and the D-Bus
multimedia keys support?

Comment 13 Ray Strode [halfline] 2007-04-04 16:54:01 UTC
yes


Note You need to log in before you can comment on or make changes to this bug.