Bug 168629 - Installation crashes when defining SW Raid
Installation crashes when defining SW Raid
Status: CLOSED DUPLICATE of bug 160693
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
4
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-18 12:40 EDT by Alan Martello
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-19 15:36:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
anacdump.txt from crash (854.23 KB, text/plain)
2005-09-19 15:26 EDT, Alan Martello
no flags Details

  None (edit)
Description Alan Martello 2005-09-18 12:40:58 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6

Description of problem:
Using graphical installation on a system with two 80GB hard drives intended to run as RAID1. Ran Disk Druid in manual mode and setup partitions as described here http://aplawrence.com/Linux/lvm.html. After it created the SW Raid partition, an error was generated indicating that the new partition would not be recognized until after a reboot. I said ignore and the installer crashed.

Upon reboot, one of the drives correctly had SW Raid partitions. Went through the entire process again, and again, after creating the SW Raid partitions on the other drive, an error was generated indicating the new partition would not be recognized until after a reboot. I said ignore again and the installer crashed.

Upon reboot, manually enterred all information into Disk Druid a third time, everything ran fine, assumedly since the SW Raid partitions were already created.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Configure 2 disks with 3 partitions each (/boot, swap and /) where /boot and / are setup for sw mirroring. Also / is setup using LVM on top of SW mirroring

2. Crashes after warning about new partitions created and ignoring need to reboot.

3. Repeat step 1

4. Crashes a second time after warning about new partitions created and ignoring need to reboot.

5. Repeat step 1

6. Installation proceeds fine.

Expected Results:  Should have either
A) worked without reboot or
B) told me to reboot after saving a config file so I would not have to enter the same data 3 times to get it to work

Additional info:
Comment 1 Jeremy Katz 2005-09-19 14:21:57 EDT
Can you provide the complete traceback you receive?
Comment 2 Alan Martello 2005-09-19 15:26:06 EDT
Created attachment 118998 [details]
anacdump.txt from crash
Comment 3 Jeremy Katz 2005-09-19 15:36:30 EDT

*** This bug has been marked as a duplicate of 160693 ***

Note You need to log in before you can comment on or make changes to this bug.