Bug 1686636 - podman cannot be installed due to dependency on conmon (subpackage of retired / moved to module cri-o)
Summary: podman cannot be installed due to dependency on conmon (subpackage of retired...
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: podman   
(Show other bugs)
Version: 30
Hardware: All
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Lokesh Mandvekar
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: openqa AcceptedBlocker
Keywords:
: 1686926 (view as bug list)
Depends On:
Blocks: BetaBlocker, F30BetaBlocker
TreeView+ depends on / blocked
 
Reported: 2019-03-07 22:48 UTC by Adam Williamson
Modified: 2019-03-12 20:00 UTC (History)
11 users (show)

Fixed In Version: podman-1.1.2-2.dev.git0ad9b6b.fc30
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2019-03-12 20:00:54 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Adam Williamson 2019-03-07 22:48:40 UTC
In current Rawhide (Fedora-Rawhide-20190306.n.1), podman cannot be installed due to an unresolved dependency on conmon.

conmon is a subpackage of cri-o. Digging into it a bit, it seems the cri-o packager decided to retire the non-modular package:

https://src.fedoraproject.org/rpms/cri-o/c/486f8184bbf0ff4c04de2aa72f438210844c45ee?branch=master

but did not (as they presumably should have done) get cri-o signed off to have a default module stream:

https://pagure.io/releng/fedora-module-defaults/tree/master

which means nothing outside of the module can properly depend on it, AIUI.

So, either podman needs to stop depending on conmon, or the cri-o situation needs to be sorted out. CCing the cri-o packager.

This breaks some openQA install tests, where podman winds up in the package set.

Comment 1 Adam Williamson 2019-03-07 22:49:12 UTC
Oh, it seems the podman owner is also the cri-o maintainer, which simplifies things. :P

Comment 2 Adam Williamson 2019-03-08 17:02:54 UTC
*** Bug 1686926 has been marked as a duplicate of this bug. ***

Comment 3 Adam Williamson 2019-03-08 17:03:47 UTC
pwhalen says this also affects F30.

Comment 4 Lukas Slebodnik 2019-03-08 23:15:25 UTC
(In reply to Adam Williamson from comment #0)
> In current Rawhide (Fedora-Rawhide-20190306.n.1), podman cannot be installed
> due to an unresolved dependency on conmon.
> 

Description says rawhide but this BZ is for fedora 30. Which is not the same.

And fedora 30 does not have conmon in module

rpm -q podman conmon
podman-1.0.1-31.dev.git228d1cb.fc30.x86_64
conmon-1.12.0-13.dev.gitc4f232a.fc30.x86_64 

BTW rawhide(f31) was fixed by
https://src.fedoraproject.org/rpms/podman/c/7f12a84be2b7fec54ad276e90fa574409b8ba09a?branch=master

I would say this BZ can be closed.

Comment 5 Adam Williamson 2019-03-09 03:33:26 UTC
"Description says rawhide but this BZ is for fedora 30. Which is not the same."

It applies to both. See comment #3. It's assigned to 30 as fixing it in 30 is more critical (and requires blocker bureaucracy).

"And fedora 30 does not have conmon in module

rpm -q podman conmon
podman-1.0.1-31.dev.git228d1cb.fc30.x86_64
conmon-1.12.0-13.dev.gitc4f232a.fc30.x86_64"

You are probably looking at old information. (also, 'rpm -q' is telling you what you have installed; a package that is retired is not automatically uninstalled unless something obsoletes it). The f30 branch in git is certainly retired:

https://src.fedoraproject.org/rpms/cri-o/tree/f30

there has not been a successful F30 compose for some time (we are working on this), but if you look at recent failed composes, they do not have conmon:

https://kojipkgs.fedoraproject.org/compose/branched/Fedora-30-20190308.n.0/compose/Everything/x86_64/os/Packages/c/

"BTW rawhide(f31) was fixed by
https://src.fedoraproject.org/rpms/podman/c/7f12a84be2b7fec54ad276e90fa574409b8ba09a?branch=master"

I'll have to check if that is a correct fix, thanks.

"I would say this BZ can be closed."

not yet :)

Comment 6 Adam Williamson 2019-03-11 16:42:01 UTC
As sgallagh points out, this is an automatic blocker: "Bugs which entirely prevent the composition of one or more of the release-blocking images required to be built for a currently-pending (pre-)release" - this prevents the compose of aarch64 and armhfp Server disk images. Marking as accepted.

Comment 7 Adam Williamson 2019-03-11 16:42:23 UTC
correction, only aarch64 Server disk image is blocking, not armhfp.

Comment 8 Adam Williamson 2019-03-11 17:11:44 UTC
*** Bug 1686813 has been marked as a duplicate of this bug. ***

Comment 9 Dusty Mabe 2019-03-12 13:40:52 UTC
There was a fix committed:
https://src.fedoraproject.org/rpms/podman/c/6af34192250f0570043f98778944991eccf022fd?branch=f30

and a few new builds of podman done this morning. One of them bumps versions of podman:
https://koji.fedoraproject.org/koji/packageinfo?packageID=26289

Comment 10 Fedora Update System 2019-03-12 13:46:37 UTC
podman-1.1.2-1.dev.git0ad9b6b.fc30 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-a449d35971

Comment 11 Lokesh Mandvekar 2019-03-12 13:48:15 UTC
(In reply to Dusty Mabe from comment #9)
> There was a fix committed:
> https://src.fedoraproject.org/rpms/podman/c/
> 6af34192250f0570043f98778944991eccf022fd?branch=f30
> 
> and a few new builds of podman done this morning. One of them bumps versions
> of podman:
> https://koji.fedoraproject.org/koji/packageinfo?packageID=26289

I noticed f29 was bumped to 1.1.2 by Dan Walsh but f30 wasn't. So I bumped f30 to keep upgrade path straight.

Comment 12 Fedora Update System 2019-03-12 14:24:16 UTC
podman-1.1.2-2.dev.git0ad9b6b.fc30 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-23ba2f111f

Comment 13 Adam Williamson 2019-03-12 15:26:22 UTC
*** Bug 1686813 has been marked as a duplicate of this bug. ***

Comment 14 Adam Williamson 2019-03-12 15:28:40 UTC
For the record, I was not convinced that "fix" was correct, but per https://bugzilla.redhat.com/show_bug.cgi?id=1686813#c6 it probably is. (Well, I'm not sure that bundling conmon into podman is really legit, but since it's a thing that's being done, removing the dependency is probably fine).

Comment 15 Peter Robinson 2019-03-12 15:40:22 UTC
It seems to be correct from my testing in the IoT compose.

Comment 16 Fedora Update System 2019-03-12 16:09:11 UTC
podman-1.1.2-2.dev.git0ad9b6b.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-23ba2f111f

Comment 17 Fedora Update System 2019-03-12 20:00:54 UTC
podman-1.1.2-2.dev.git0ad9b6b.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.