Bug 1686651 - QEMU IOTEST 219 fails intermittently with output mismatch
Summary: QEMU IOTEST 219 fails intermittently with output mismatch
Keywords:
Status: CLOSED DEFERRED
Alias: None
Product: Red Hat Enterprise Linux Advanced Virtualization
Classification: Red Hat
Component: qemu-kvm
Version: 8.1
Hardware: s390x
OS: Linux
unspecified
unspecified
Target Milestone: rc
: 8.0
Assignee: Max Reitz
QA Contact: Gu Nini
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-07 23:27 UTC by Karen Mezick
Modified: 2019-08-16 23:21 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-08-16 23:21:07 UTC
Type: Bug


Attachments (Terms of Use)

Comment 1 Karen Mezick 2019-03-11 18:09:45 UTC
This is an update to the original Description above.

The qemu iotest 219 for -qcow2 fails intermittently on s390x with unexpected outputs. 

For example:

  Expected    ---> -{"return": [{"current-progress": 65536, "id": "job0", "status": "paused", "total-progress": 4194304, "type": "mirror"}]}
  Unexpected  ---> +{"return": [{"current-progress": 0, "id": "job0", "status": "paused", "total-progress": 0, "type": "mirror"}]}

  Expected    ---> -{"return": [{"current-progress": 131072, "id": "job0", "status": "running", "total-progress": 4194304, "type": "mirror"}]}
  Unexpected  ---> +{"return": [{"current-progress": 0, "id": "job0", "status": "running", "total-progress": 4194304, "type": "mirror"}]}

Comment 4 Max Reitz 2019-05-16 15:59:24 UTC
Reproduced upstream, I’ll send a patch.

Max

Comment 5 Ademar Reis 2019-08-16 23:21:07 UTC
Closing qemu iotest BZs because the rpm build environment is not reliable and we're removing the run from %check (see bug 1742197).

We'll run the tests as part of our CI and track the failures using different BZs or tasks.

Some of these bugs are real and are worth fixing upstream, but there's no *need* to track them here. With that said, feel free to reopen the BZ if you *want* to track it.


Note You need to log in before you can comment on or make changes to this bug.