Bug 168687 - yum error message on Conflicts: is backwards
yum error message on Conflicts: is backwards
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks: FC5Blocker
  Show dependency treegraph
 
Reported: 2005-09-19 11:20 EDT by Nils Philippsen
Modified: 2014-01-21 17:52 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-27 19:24:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nils Philippsen 2005-09-19 11:20:04 EDT
Description of problem:

yum update as of now:
[...]
--> Processing Conflict: kudzu conflicts kernel < 2.6.13
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
--> Running transaction check
Error: Unable to satisfy dependencies
Error: Package kudzu needs kernel < 2.6.13, this is not available.

I think that kudzu isn't needed or wanted anymore (at least for the time being),
so it(s existing versions) should be obsoleted by the kernel so yum/up2date can
do the right thing.

Version-Release number of selected component (if applicable):
kernel-2.6.13-1.1558_FC5

How reproducible:
Easy.

Steps to Reproduce:
1. yum --obsoletes update
  
Actual results:
See above.

Expected results:
No error message about kudzu conflicting with the new kernel, kudzu gets kicked out.

Additional info:
Comment 1 Dave Jones 2005-09-21 22:40:39 EDT
this error only gets thrown if you have any < 2.6.13 kernels installed.
this may prove problematic for upgrades. Bill ?
Comment 2 Bill Nottingham 2005-09-22 00:27:31 EDT
The error message is wrong.

kudzu *conflicts* with kernels < 2.6.13.
Comment 3 Nils Philippsen 2005-09-22 03:11:47 EDT
In that case, the yum error message should be fixed (to reflect what it
correctly reported a few lines above) and yum should maybe offer to remove the
offending kernel packages? IIRC anaconda does the right thing, namely forget the
installed kernel packages and only keep the one that came along on the
installation media.

Anyway, this should only happen when doing a "yum update" from FC4 to Rawhide or
FC5 (or within Rawhide), so it's not a big deal.
Comment 4 Jeremy Katz 2005-09-22 13:36:47 EDT
The error message is definitely wrong :-)
Comment 5 Peter Ennis 2005-10-13 01:02:49 EDT
Ref: Bug 170585
Running rawhide
Google did not reveal a solution
I will try yum --obsoletes update

PFE
Comment 6 Peter Ennis 2005-10-13 01:19:07 EDT

It did not help :(

--> Populating transaction set with selected packages. Please wait.
--> Running transaction check
Error: Unable to satisfy dependencies
Error: Package initscripts needs kernel < 2.6.12, this is not available.
Error: Package kudzu needs kernel < 2.6.13, this is not available.
[developer@lfs ~]$

[developer@lfs ~]$ uname -r
2.6.11-1.1177_FC4
[developer@lfs ~]$
Comment 8 Jeremy Katz 2006-02-27 19:24:10 EST
Fixed in upstream CVS

Note You need to log in before you can comment on or make changes to this bug.